aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authordv@pseudoterminal.org <dv@pseudoterminal.org>2013-04-09 09:58:08 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-11 11:33:38 +0200
commit17f37f29b64c9e3d2e991827d265af570bc2b491 (patch)
tree11489839a925abdd04f02836c54c7d105575e563 /meta-multimedia
parentf5930ea4afbfb006190f7ee8afc08f939ac363c7 (diff)
downloadmeta-openembedded-17f37f29b64c9e3d2e991827d265af570bc2b491.tar.gz
add recipe for mpg123, a decoder for MPEG-1 layer 1, 2, and 3
mpg123 consists of a decoder library, and a command line application. The application can be used to playback and dump decoded mp1/mp2/mp3 files. The library can be integrated in other applications. CPU usage is minimal. Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/mpg123/mpg123_1.15.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/mpg123/mpg123_1.15.3.bb b/meta-multimedia/recipes-multimedia/mpg123/mpg123_1.15.3.bb
new file mode 100644
index 0000000000..e2e41ea412
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/mpg123/mpg123_1.15.3.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Audio decoder for MPEG-1 Layer 1/2/3"
+DESCRIPTION = "The core of mpg123 is an MPEG-1 Layer 1/2/3 decoding library, which can be used by other programs. \
+mpg123 also comes with a command-line tool which can playback using ALSA, PulseAudio, OSS, and several other APIs, \
+and also can write the decoded audio to WAV."
+HOMEPAGE = "http://mpg123.de/"
+BUGTRACKER = "http://sourceforge.net/p/mpg123/bugs/"
+SECTION = "multimedia"
+
+LICENSE = "LGPLv2.1"
+LICENSE_FLAGS = "commercial"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a7aa23a2b646eca38ad4eeb7a853761c"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/mpg123/mpg123/${PV}/mpg123-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "f734f9e2982f398a1c919475fc0b3798"
+SRC_URI[sha256sum] = "b6b1aef887835f83ac3d4acb5701ae619041fc60d76548ad779a409080338df7"
+
+S = "${WORKDIR}/mpg123-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " \
+ --enable-shared \
+ ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-cpu=neon', '', d)} \
+ ${@bb.utils.contains('TUNE_FEATURES', 'altivec', '--with-cpu=altivec', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'alsa', '--with-default-audio=alsa', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', '--with-default-audio=pulse', '', d)} \
+ "
+