aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2022-12-09 01:54:22 -0800
committerKhem Raj <raj.khem@gmail.com>2022-12-09 10:39:27 -0800
commit178123a0066c40db1e75d018dc65f056fb03b826 (patch)
tree06eafbe05f2a42ae7b380096f42f81ced2020645 /meta-networking/recipes-connectivity
parentec96eb577bd518b89e2e7834bd569ba269df458f (diff)
downloadmeta-openembedded-178123a0066c40db1e75d018dc65f056fb03b826.tar.gz
networkmanager: fix dhcpcd PACKAGECONFIG
Without this patch, even if dhcpcd is enabled, the NetworkManager cannot find it. Below are the messages from NetworkMananger: dhcp: init: DHCP client 'dhcpcd' not available dhcp: init: Using DHCP client 'internal' The problem is that dhcpcd needs to be specified as a path, otherwise NetworkManager tries to find it in /usr/sbin/dhcpcd. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/networkmanager/networkmanager_1.40.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.40.0.bb b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.40.0.bb
index 10241e12a6..110b499aaa 100644
--- a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.40.0.bb
+++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.40.0.bb
@@ -104,7 +104,7 @@ PACKAGECONFIG[ovs] = "-Dovs=true,-Dovs=false,jansson"
PACKAGECONFIG[audit] = "-Dlibaudit=yes,-Dlibaudit=no"
PACKAGECONFIG[selinux] = "-Dselinux=true,-Dselinux=false,libselinux"
PACKAGECONFIG[vala] = "-Dvapi=true,-Dvapi=false"
-PACKAGECONFIG[dhcpcd] = "-Ddhcpcd=yes,-Ddhcpcd=no,,dhcpcd"
+PACKAGECONFIG[dhcpcd] = "-Ddhcpcd=${base_sbindir}/dhcpcd,-Ddhcpcd=no,,dhcpcd"
PACKAGECONFIG[dhclient] = "-Ddhclient=yes,-Ddhclient=no,,dhcp"
PACKAGECONFIG[concheck] = "-Dconcheck=true,-Dconcheck=false"