aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2020-04-26 09:18:22 +0800
committerKhem Raj <raj.khem@gmail.com>2020-04-26 23:10:57 -0700
commit1f35a5af9bc2d6fa5b17c243eaf232bf56a79568 (patch)
tree4583c214266b7e59267b0f4ef719d289967d750f /meta-networking/recipes-connectivity
parentbc4fa976e48308735fbe45fc3f22def60383baee (diff)
downloadmeta-openembedded-1f35a5af9bc2d6fa5b17c243eaf232bf56a79568.tar.gz
kea: improve reproducibility
There are some shell scripts such as kea-admin, upgrade_4.0_to_5.0.sh, wipe_data.sh and etc contain build path. Actually the build path is meanlingless on the target, so replace abs_top_builddir to abs_top_builddir_placeholder to avoid expanding abs_top_builddir which introduces build path. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/kea/kea_1.7.6.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/kea/kea_1.7.6.bb b/meta-networking/recipes-connectivity/kea/kea_1.7.6.bb
index 51e361c587..4e221c39ee 100644
--- a/meta-networking/recipes-connectivity/kea/kea_1.7.6.bb
+++ b/meta-networking/recipes-connectivity/kea/kea_1.7.6.bb
@@ -35,6 +35,10 @@ BUILD_OPTIMIZATION_append_mipsel = " -O"
do_configure_prepend_class-target() {
mkdir -p ${B}/src/lib/log/compiler/
ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler
+ # replace abs_top_builddir to avoid introducing the build path
+ # don't expand the abs_top_builddir on the target as the abs_top_builddir is meanlingless on the target
+ find ${S} -type f -name *.sh.in | xargs sed -i "s:@abs_top_builddir@:@abs_top_builddir_placeholder@:g"
+ sed -i "s:@abs_top_srcdir@:@abs_top_srcdir_placeholder@:g" ${S}/src/bin/admin/kea-admin.in
}
do_install_append_class-target() {