aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-19 16:32:05 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-22 09:56:34 -0800
commit66454b26ff49c6cca3dd8d32832078cfa05cd5ef (patch)
tree62079bca2894e0e5045162292975f71d74ae3ab5 /meta-networking/recipes-connectivity
parentff7839adcb9348733fab8ef7358d15e594afda07 (diff)
downloadmeta-openembedded-66454b26ff49c6cca3dd8d32832078cfa05cd5ef.tar.gz
meta-networking: Remove using python2
This change makes the parsing go though, we still might have build issues, which will be reported in world builds seprately Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/crda/crda_3.18.bb2
-rw-r--r--meta-networking/recipes-connectivity/freeradius/freeradius_3.0.19.bb4
-rw-r--r--meta-networking/recipes-connectivity/python-networkmanager/python3-networkmanager_2.1.bb (renamed from meta-networking/recipes-connectivity/python-networkmanager/python-networkmanager_2.1.bb)4
-rw-r--r--meta-networking/recipes-connectivity/ufw/ufw_0.33.bb6
4 files changed, 8 insertions, 8 deletions
diff --git a/meta-networking/recipes-connectivity/crda/crda_3.18.bb b/meta-networking/recipes-connectivity/crda/crda_3.18.bb
index 7c925b2529..d3c00424db 100644
--- a/meta-networking/recipes-connectivity/crda/crda_3.18.bb
+++ b/meta-networking/recipes-connectivity/crda/crda_3.18.bb
@@ -18,7 +18,7 @@ SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz \
SRC_URI[md5sum] = "0431fef3067bf503dfb464069f06163a"
SRC_URI[sha256sum] = "43fcb9679f8b75ed87ad10944a506292def13e4afb194afa7aa921b01e8ecdbf"
-inherit python-dir pythonnative siteinfo
+inherit python3-dir python3native siteinfo
# Recursive make problem
EXTRA_OEMAKE = "MAKEFLAGS= DESTDIR=${D} LIBDIR=${libdir}/crda LDLIBREG='-Wl,-rpath,${libdir}/crda -lreg' \
diff --git a/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.19.bb b/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.19.bb
index 31e6978d6f..8887433062 100644
--- a/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.19.bb
+++ b/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.19.bb
@@ -96,9 +96,9 @@ PACKAGECONFIG[rlm-eap-pwd] = "--with-rlm_eap_pwd, --without-rlm_eap_pwd"
inherit useradd autotools-brokensep update-rc.d systemd
# This is not a cpan or python based package, but it needs some definitions
-# from cpan-base and python-dir bbclasses for building rlm_perl and rlm_python
+# from cpan-base and python3-dir bbclasses for building rlm_perl and rlm_python
# correctly.
-inherit cpan-base python-dir
+inherit cpan-base python3-dir
# The modules subdirs also need to be processed by autoreconf. Use autogen.sh
# in order to handle the subdirs correctly.
diff --git a/meta-networking/recipes-connectivity/python-networkmanager/python-networkmanager_2.1.bb b/meta-networking/recipes-connectivity/python-networkmanager/python3-networkmanager_2.1.bb
index 3aa41f1add..91a6edd241 100644
--- a/meta-networking/recipes-connectivity/python-networkmanager/python-networkmanager_2.1.bb
+++ b/meta-networking/recipes-connectivity/python-networkmanager/python3-networkmanager_2.1.bb
@@ -8,6 +8,6 @@ SRC_URI[md5sum] = "f638d854a3639fb37c0e06d1092a771e"
SRC_URI[sha256sum] = "aef1e34d98d7bec7cc368e0ca0f2e97493f9b5ebe6d7103f8f6460cfca3dc6fc"
PYPI_PACKAGE = "python-networkmanager"
-inherit pypi setuptools
+inherit pypi setuptools3
-RDEPENDS_${PN} = "networkmanager python-dbus python-six"
+RDEPENDS_${PN} = "networkmanager python3-dbus python3-six"
diff --git a/meta-networking/recipes-connectivity/ufw/ufw_0.33.bb b/meta-networking/recipes-connectivity/ufw/ufw_0.33.bb
index 6ff103c770..d620e88eb4 100644
--- a/meta-networking/recipes-connectivity/ufw/ufw_0.33.bb
+++ b/meta-networking/recipes-connectivity/ufw/ufw_0.33.bb
@@ -20,12 +20,12 @@ SRC_URI = " \
SRC_URI[md5sum] = "3747b453d76709e5a99da209fc0bb5f5"
SRC_URI[sha256sum] = "5f85a8084ad3539b547bec097286948233188c971f498890316dec170bdd1da8"
-inherit setuptools features_check
+inherit setuptools3 features_check
RDEPENDS_${PN} = " \
iptables \
- python \
- python-modules \
+ python3 \
+ python3-modules \
"
RRECOMMENDS_${PN} = " \