aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2013-03-29 15:25:02 +0100
committerJoe MacDonald <joe.macdonald@windriver.com>2013-04-02 08:53:13 -0400
commit6fc248efc70dc38626b5f2f518900df2cee78959 (patch)
tree257db5b9fa1d381a5f85488e23c971ef3c77ae9f /meta-networking/recipes-connectivity
parent7d6f5f468566b7f475da246328ff95844ba60f61 (diff)
downloadmeta-openembedded-6fc248efc70dc38626b5f2f518900df2cee78959.tar.gz
crda: add 1.1.3
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/crda/crda_1.1.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb b/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb
new file mode 100644
index 0000000000..d736c7a2de
--- /dev/null
+++ b/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Wireless Central Regulatory Domain Agent"
+HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA"
+
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c"
+
+
+DEPENDS = "python-m2crypto-native python-native libgcrypt libnl"
+
+SRC_URI = "http://wireless.kernel.org/download/crda/${P}.tar.bz2;name=crda \
+ http://wireless.kernel.org/download/wireless-regdb/regulatory.bins/2013.01.11-regulatory.bin;name=bin \
+ "
+SRC_URI[crda.md5sum] = "29579185e06a75675507527243d28e5c"
+SRC_URI[crda.sha256sum] = "aa8a7fe92f0765986c421a5b6768a185375ac210393df0605ee132f6754825f0"
+SRC_URI[bin.md5sum] = "e0c8a5ca63fb8bf803213f9a0c90b50b"
+SRC_URI[bin.sha256sum] = "b1ee0b20c123c612dfdb6851ab42c01666f66fb583e0e590942f19bb54cf84be"
+
+inherit python-dir pythonnative
+# Recursive make problem
+EXTRA_OEMAKE = "MAKEFLAGS= DESTDIR=${D}"
+
+do_compile() {
+ oe_runmake all_noverify
+}
+
+do_install() {
+ oe_runmake install
+
+ install -d ${D}${libdir}/crda/
+
+ install -m 0644 ${WORKDIR}/2013.01.11-regulatory.bin ${D}${libdir}/crda/regulatory.bin
+}
+
+
+RDEPENDS_${PN} = "udev"
+FILES_${PN} += "${libdir}crda/regulatory.bin \
+ ${base_libdir}/udev/rules.d/85-regulatory.rules \
+ "