aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/autofs
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2013-10-24 12:47:39 +0800
committerJoe MacDonald <joe@deserted.net>2013-10-24 14:05:35 -0400
commitddfcd90894a9b16e13b471d75745ae7b9cf7fca7 (patch)
tree2b3c04759810e60d906b70bc10e62a482b831bdd /meta-networking/recipes-daemons/autofs
parentadb7af3fe95668a85c79acc6f0a2dafc0a96f7e1 (diff)
downloadmeta-openembedded-ddfcd90894a9b16e13b471d75745ae7b9cf7fca7.tar.gz
autofs: fix do_install failure and remove unused /var/run directory
If ${D}/run doesn't exist, the following statement will have non-zero exit code, which leads to do_install failure. test -d ${D}/run && rmdir ${D}/run Modify it to use the if statement to make the do_install task succeed no matter ${D}/run exists or not. Also, this patch removes the unused /var/run directory. Leaving that directory there will result in /run directory created before splitting package, which in turn lead to 'installed-vs-shipped' QA error or QA warning. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking/recipes-daemons/autofs')
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
index f8df0ef187..c4eea317bc 100644
--- a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
@@ -96,7 +96,12 @@ do_configure_prepend () {
}
do_install_append () {
- test -d ${D}/run && rmdir ${D}/run
+ if [ -d ${D}/run ]; then
+ rmdir ${D}/run
+ fi
+ if [ -d ${D}${localstatedir}/run ]; then
+ rmdir ${D}${localstatedir}/run
+ fi
}
INSANE_SKIP_${PN} = "dev-so"