aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-03-06 18:06:48 -0800
committerKhem Raj <raj.khem@gmail.com>2020-03-08 08:15:34 -0700
commita367e54deb7c388a60cfddc356a695180bb67954 (patch)
treea21f477000d8d002a3517b997d8f521155b83da0 /meta-networking/recipes-extended
parent3be47e74240d48c72ff0c51ab8b152a07b615db5 (diff)
downloadmeta-openembedded-a367e54deb7c388a60cfddc356a695180bb67954.tar.gz
kronosnet: Add recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-extended')
-rw-r--r--meta-networking/recipes-extended/kronosnet/kronosnet_1.15.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-networking/recipes-extended/kronosnet/kronosnet_1.15.bb b/meta-networking/recipes-extended/kronosnet/kronosnet_1.15.bb
new file mode 100644
index 0000000000..24aa27a87b
--- /dev/null
+++ b/meta-networking/recipes-extended/kronosnet/kronosnet_1.15.bb
@@ -0,0 +1,17 @@
+# Copyright (C) 2020 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = " Kronosnet, often referred to as knet, is a network abstraction layer designed for High Availability use cases, where redundancy, security, fault tolerance and fast fail-over are the core requirements of your application."
+HOMEPAGE = "https://kronosnet.org/"
+LICENSE = "GPL-2.0+ & LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING.applications;md5=751419260aa954499f7abaabaa882bbe \
+ file://COPYING.libraries;md5=2d5025d4aa3495befef8f17206a5b0a1"
+SECTION = "libs"
+DEPENDS = "doxygen-native libqb-native libxml2-native bzip2 libqb libxml2 libnl lksctp-tools lz4 lzo openssl nss xz zlib zstd"
+
+SRCREV = "0ba5985c3ddec8429b989f0e7bd3324f53e0a9b0"
+SRC_URI = "git://github.com/kronosnet/kronosnet;protocol=https;branch=stable1"
+
+inherit autotools
+
+S = "${WORKDIR}/git"