aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-irc
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-01-03 13:17:14 +0800
committerKhem Raj <raj.khem@gmail.com>2022-01-05 11:10:02 -0800
commitac69402cc6f9f5bf4aeab32266930dbae37453e1 (patch)
tree9ae83f862976059df4bfe4da9f40158bf9090202 /meta-networking/recipes-irc
parenta8a0f805537dda249f4162241fa5f76e978d75a0 (diff)
downloadmeta-openembedded-ac69402cc6f9f5bf4aeab32266930dbae37453e1.tar.gz
weechat: upgrade 3.0 -> 3.4
refresh 0001-use-pkg-config-for-gcrypt-instead.patch License-Update: Url changed from "https://www.gnu.org/philosophy/why-not-lgpl.html" to "https://www.gnu.org/licenses/why-not-lgpl.html" Changelog: ========= New features ---------------- core: add support of static arrays in hdata core: add command /toggle api: add parameters pointers, extra_vars and options in function hdata_search api: add user variables in evaluation of expressions with "define:name,value" api: add IRC message parameters "param1" to "paramN" and "num_params" in output of irc_message_parse irc: allow quotes around IRC message in command /server fakerecv trigger: hide key and password in command "/msg nickserv setpass nick key password" trigger: add support of option "-server" when hiding passwords in command /msg nickserv register Bug fixes --------------- core: fix memory leak in evaluated expression "split:number,seps,flags,xxx" when multiple "strip_items" are given core: fix random integer number with large range in evaluation of expressions on GNU/Hurd core: fix access to integer/long/time arrays in hdata api: fix search of option when the section is not given in functions config_search_option and config_search_section_option irc: fix join of channels with long name (issue #1717) irc: fix parsing of parameters in all IRC messages (issue #1666) irc: fix parsing of CAP message when there is no prefix (issue #1707) irc: fix parsing of TAGMSG message when there is a colon before the channel Documentation --------------- doc: remove tester's guide doc: add dark theme (automatic, following browser/desktop settings) doc: make build reproducible doc: disable web fonts doc: switch from prettify to pygments for syntax highlighting Tests -------------- core: add build with CMake and Ninja in CI core: add build on macOS 11 in CI Build ------------ ruby: add detection of Ruby 3.0 (issue #1721, issue #1605) core: add targets "changelog" and "rn" to build HTML version of ChangeLog and release notes (CMake build only) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-irc')
-rw-r--r--meta-networking/recipes-irc/weechat/weechat/0001-use-pkg-config-for-gcrypt-instead.patch14
-rw-r--r--meta-networking/recipes-irc/weechat/weechat_3.4.bb (renamed from meta-networking/recipes-irc/weechat/weechat_3.0.bb)4
2 files changed, 9 insertions, 9 deletions
diff --git a/meta-networking/recipes-irc/weechat/weechat/0001-use-pkg-config-for-gcrypt-instead.patch b/meta-networking/recipes-irc/weechat/weechat/0001-use-pkg-config-for-gcrypt-instead.patch
index 0717e96546..4a33dd7204 100644
--- a/meta-networking/recipes-irc/weechat/weechat/0001-use-pkg-config-for-gcrypt-instead.patch
+++ b/meta-networking/recipes-irc/weechat/weechat/0001-use-pkg-config-for-gcrypt-instead.patch
@@ -28,10 +28,10 @@ Index: weechat-2.7.1/cmake/FindGCRYPT.cmake
if(LIBGCRYPT_CONFIG_EXECUTABLE)
-- exec_program(${LIBGCRYPT_CONFIG_EXECUTABLE} ARGS --libs RETURN_VALUE _return_VALUE OUTPUT_VARIABLE GCRYPT_LDFLAGS)
-- exec_program(${LIBGCRYPT_CONFIG_EXECUTABLE} ARGS --cflags RETURN_VALUE _return_VALUE OUTPUT_VARIABLE GCRYPT_CFLAGS)
-+ exec_program(${LIBGCRYPT_CONFIG_EXECUTABLE} ARGS libgcrypt --libs RETURN_VALUE _return_VALUE OUTPUT_VARIABLE GCRYPT_LDFLAGS)
-+ exec_program(${LIBGCRYPT_CONFIG_EXECUTABLE} ARGS libgcrypt --cflags RETURN_VALUE _return_VALUE OUTPUT_VARIABLE GCRYPT_CFLAGS)
-
- if(${GCRYPT_CFLAGS} MATCHES "\n")
- set(GCRYPT_CFLAGS " ")
+- execute_process(COMMAND ${LIBGCRYPT_CONFIG_EXECUTABLE} --libs RESULT_VARIABLE _return_VALUE OUTPUT_VARIABLE GCRYPT_LDFLAGS OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_QUIET)
+- execute_process(COMMAND ${LIBGCRYPT_CONFIG_EXECUTABLE} --cflags RESULT_VARIABLE _return_VALUE OUTPUT_VARIABLE GCRYPT_CFLAGS OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_QUIET)
++ execute_process(COMMAND ${LIBGCRYPT_CONFIG_EXECUTABLE} libgcrypt --libs RESULT_VARIABLE _return_VALUE OUTPUT_VARIABLE GCRYPT_LDFLAGS OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_QUIET)
++ execute_process(COMMAND ${LIBGCRYPT_CONFIG_EXECUTABLE} libgcrypt --cflags RESULT_VARIABLE _return_VALUE OUTPUT_VARIABLE GCRYPT_CFLAGS OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_QUIET)
+
+ if(NOT DEFINED ${GCRYPT_CFLAGS})
+ set(GCRYPT_CFLAGS " ")
diff --git a/meta-networking/recipes-irc/weechat/weechat_3.0.bb b/meta-networking/recipes-irc/weechat/weechat_3.4.bb
index 9f7e392973..ca404ebc87 100644
--- a/meta-networking/recipes-irc/weechat/weechat_3.0.bb
+++ b/meta-networking/recipes-irc/weechat/weechat_3.4.bb
@@ -2,7 +2,7 @@ SUMMARY = "Full-featured IRC plugin: multi-servers, proxy support, IPv6, SASL au
HOMEPAE = "https://weechat.org/"
SECTION = "net"
LICENSE = "GPLv3"
-LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
DEPENDS = "openssl zlib icu libgcrypt gnutls curl aspell"
@@ -10,7 +10,7 @@ SRC_URI = "https://weechat.org/files/src/weechat-${PV}.tar.xz \
file://0001-use-pkg-config-for-gcrypt-instead.patch \
"
-SRC_URI[sha256sum] = "6cb7d25a363b66b835f1b9f29f3580d6f09ac7d38505b46a62c178b618d9f1fb"
+SRC_URI[sha256sum] = "7cd3dcc7029e888de49e13ebbcc3749586ff59c9d97f89f5eeb611067c7bb94c"
inherit cmake pkgconfig