aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-irc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-networking/recipes-irc
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-irc')
-rw-r--r--meta-networking/recipes-irc/weechat/weechat_3.0.bb6
-rw-r--r--meta-networking/recipes-irc/znc/znc_1.8.2.bb4
2 files changed, 5 insertions, 5 deletions
diff --git a/meta-networking/recipes-irc/weechat/weechat_3.0.bb b/meta-networking/recipes-irc/weechat/weechat_3.0.bb
index 6a0c9386c2..9f7e392973 100644
--- a/meta-networking/recipes-irc/weechat/weechat_3.0.bb
+++ b/meta-networking/recipes-irc/weechat/weechat_3.0.bb
@@ -18,16 +18,16 @@ PACKAGECONFIG ??= " ncurses python"
PACKAGECONFIG[ncurses] = "-DENABLE_NCURSES=ON,-DENABLE_NCURSES=OFF,ncurses"
PACKAGECONFIG[python] = "-DENABLE_PYTHON=ON,-DENABLE_PYTHON=OFF,python3,python3"
-EXTRA_OECMAKE_append = " -DENABLE_PHP=OFF -DENABLE_TCL=OFF -DENABLE_LUA=OFF -DENABLE_JAVASCRIPT=OFF -DENABLE_RUBY=OFF -DENABLE_GUILE=OFF -DENABLE_PERL=OFF -DENABLE_ASPELL=ON"
+EXTRA_OECMAKE:append = " -DENABLE_PHP=OFF -DENABLE_TCL=OFF -DENABLE_LUA=OFF -DENABLE_JAVASCRIPT=OFF -DENABLE_RUBY=OFF -DENABLE_GUILE=OFF -DENABLE_PERL=OFF -DENABLE_ASPELL=ON"
-do_configure_prepend(){
+do_configure:prepend(){
# Make sure we get dependencies from recipe-sysroot
sed -i -e 's# /usr/bin# ${RECIPE_SYSROOT}/${bindir}/#g' ${S}/cmake/FindPerl.cmake
sed -i -e 's# /usr/local/bin##g' ${S}/cmake/FindPerl.cmake
sed -i -e 's# /usr/pkg/bin##g' ${S}/cmake/FindPerl.cmake
}
-do_install_append(){
+do_install:append(){
rm -rf ${D}/${datadir}
}
diff --git a/meta-networking/recipes-irc/znc/znc_1.8.2.bb b/meta-networking/recipes-irc/znc/znc_1.8.2.bb
index 806d622d70..fff198d06a 100644
--- a/meta-networking/recipes-irc/znc/znc_1.8.2.bb
+++ b/meta-networking/recipes-irc/znc/znc_1.8.2.bb
@@ -23,10 +23,10 @@ PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
# ZNC has a custom autogen.sh that states that this command is needed *and* expected to fail
-do_configure_prepend() {
+do_configure:prepend() {
automake --add-missing || true
}
-do_install_append() {
+do_install:append() {
sed -i -e 's|${DEBUG_PREFIX_MAP}||g; s|--sysroot=${STAGING_DIR_TARGET}||g' ${D}${libdir}/pkgconfig/*.pc
}