aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/libtevent/libtevent_0.9.25.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-01-06 14:42:44 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-01-20 21:41:40 -0500
commitd573f980653c1a5ae21c32cdc66e3c9509089eae (patch)
tree2c4cc13a91d037ab421f80542c4e0255196bf953 /meta-networking/recipes-support/libtevent/libtevent_0.9.25.bb
parent0210ff9945988d58364fc40f1647397b86d99538 (diff)
downloadmeta-openembedded-d573f980653c1a5ae21c32cdc66e3c9509089eae.tar.gz
libtevent: upgrade to 0.9.25
Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/libtevent/libtevent_0.9.25.bb')
-rw-r--r--meta-networking/recipes-support/libtevent/libtevent_0.9.25.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/libtevent/libtevent_0.9.25.bb b/meta-networking/recipes-support/libtevent/libtevent_0.9.25.bb
new file mode 100644
index 0000000000..2ec79e96cd
--- /dev/null
+++ b/meta-networking/recipes-support/libtevent/libtevent_0.9.25.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
+HOMEPAGE = "http://tevent.samba.org"
+SECTION = "libs"
+LICENSE = "LGPLv3+"
+
+DEPENDS += "libbsd libtalloc"
+RDEPENDS_python-tevent = "python"
+
+SRC_URI = "http://samba.org/ftp/tevent/tevent-${PV}.tar.gz"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/LGPL-3.0;md5=bfccfe952269fff2b407dd11f2f3083b"
+
+SRC_URI[md5sum] = "8d01a2076cb8cd30cab40393d27043df"
+SRC_URI[sha256sum] = "fedeb0d55a11b3593b562ec09b32e44bd67619ed10e5fa10d1868adb1649c669"
+
+inherit waf-samba
+
+PACKAGECONFIG[attr] = ",,attr"
+
+SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
+
+S = "${WORKDIR}/tevent-${PV}"
+
+EXTRA_OECONF += "--disable-rpath \
+ --bundled-libraries=NONE \
+ --builtin-libraries=replace \
+ --with-libiconv=${STAGING_DIR_HOST}${prefix}\
+ --without-gettext \
+ "
+
+PACKAGES += "python-tevent python-tevent-dbg"
+
+FILES_python-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
+FILES_python-tevent-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug"