aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-04-29 17:01:13 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-10 11:02:39 +0200
commit8c709eb9fda970e06a7114c00c5e027fd3621259 (patch)
treef1a915dcefb28e9236ce0fb0b795998666974b7e /meta-networking
parentf06c454faa2cb798d3ab87ed392d827363022930 (diff)
downloadmeta-openembedded-8c709eb9fda970e06a7114c00c5e027fd3621259.tar.gz
proftpd: remove postinst - directory can be setup offline in do_install
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/proftpd/proftpd_1.3.4b.bb16
1 files changed, 5 insertions, 11 deletions
diff --git a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.4b.bb b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.4b.bb
index 28a7357864..806413bd72 100644
--- a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.4b.bb
+++ b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.4b.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.proftpd.org"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=fb0d1484d11915fa88a6a7702f1dc184"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.proftpd.org/distrib/source/${BPN}-${PV}.tar.gz \
file://make.patch \
@@ -47,6 +47,10 @@ do_install () {
install -d ${D}${sysconfdir}/default
install -m 0755 ${WORKDIR}/default ${D}${sysconfdir}/default/proftpd
+
+ # create the pub directory
+ mkdir -p ${D}/home/${FTPUSER}/pub/
+ chown -R ${FTPUSER}:${FTPGROUP} ${D}/home/${FTPUSER}/pub
}
INITSCRIPT_NAME = "proftpd"
@@ -55,13 +59,3 @@ INITSCRIPT_PARAM = "defaults 85 15"
USERADD_PACKAGES = "${PN}"
GROUPADD_PARAM_${PN} = "${FTPGROUP}"
USERADD_PARAM_${PN} = "--system -g ${FTPGROUP} ${FTPUSER}"
-
-pkg_postinst_${PN} () {
- if [ "x$D" != "x" ] ; then
- exit 1
- fi
-
- # create the pub directory
- mkdir -p /home/${FTPUSER}/pub/
- chown -R ${FTPUSER}:${FTPGROUP} /home/${FTPUSER}/pub
-}