aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei.gherzan@windriver.com>2013-03-21 14:46:31 -0700
committerJoe MacDonald <joe.macdonald@windriver.com>2013-03-22 11:14:35 -0400
commit37597429ffd4adf22f39ad8d126d43405993fdc5 (patch)
treed162aacec97ecddeec03d7533e9f709820d8562b /meta-networking
parentba80b770c8ba6e38383b9ce142af68a8a6553f2e (diff)
downloadmeta-openembedded-37597429ffd4adf22f39ad8d126d43405993fdc5.tar.gz
layer.conf: Use .= for adding to BBPATH and += to BBFILES
Fixes parsing errors which is appearing after this commit to meta-openembedded http://cgit.openembedded.org/meta-openembedded/commit/?id=3c21a46020bd0816579648f684c41dbd6333583e This triggers exception NameError: name 'base_contains' is not defined without this change Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com> Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/conf/layer.conf6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-networking/conf/layer.conf b/meta-networking/conf/layer.conf
index f26a172654..1ea2bc2eaf 100644
--- a/meta-networking/conf/layer.conf
+++ b/meta-networking/conf/layer.conf
@@ -1,9 +1,9 @@
# We have a conf and classes directory, add to BBPATH
-BBPATH := "${BBPATH}:${LAYERDIR}"
+BBPATH .= ":${LAYERDIR}"
# We have a packages directory, add to BBFILES
-BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "networking"
BBFILE_PATTERN_networking := "^${LAYERDIR}/"