aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-11-12 15:45:20 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-16 21:57:46 +0100
commita9ce55bf6d7f6e45c4006c6b4630fa49580dd5a4 (patch)
tree3cbe54349b5c044f892d5c8291554d90315504d3 /meta-networking
parente6f45e07c992178c1f65c6c85304f33fa89bbbda (diff)
downloadmeta-openembedded-a9ce55bf6d7f6e45c4006c6b4630fa49580dd5a4.tar.gz
netmap: set MACHINE_ARCH, because it depends on MACHINE_ARCH netmap-modules
* it's also using MACHINE specific variables like: STAGING_KERNEL_DIR. STAGING_KERNEL_BUILDDIR * drop suspicious: do_fetch[depends] += "netmap-modules:do_fetch" fetcher should use .lock files to prevent updating the same repository in parallel * see: http://lists.openembedded.org/pipermail/openembedded-devel/2015-September/103271.html * fixes: ERROR: netmap different signature for task do_configure.sigdata between qemux86copy and qemux86 basehash changed from 748eae270193023d79f7d6a69aa1b8d2 to 9267873ef5fa4474d5f60fc79044ab64 Variable MACHINE value changed from 'qemux86copy' to 'qemux86' Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-kernel/netmap/netmap_git.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta-networking/recipes-kernel/netmap/netmap_git.bb b/meta-networking/recipes-kernel/netmap/netmap_git.bb
index f15a626cba..a0285851a4 100644
--- a/meta-networking/recipes-kernel/netmap/netmap_git.bb
+++ b/meta-networking/recipes-kernel/netmap/netmap_git.bb
@@ -1,6 +1,7 @@
require netmap.inc
DEPENDS = "netmap-modules"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
EXTRA_OECONF = "--kernel-dir=${STAGING_KERNEL_BUILDDIR} \
--kernel-sources=${STAGING_KERNEL_DIR} \
@@ -13,8 +14,6 @@ EXTRA_OECONF = "--kernel-dir=${STAGING_KERNEL_BUILDDIR} \
"
SRC_URI += "file://0001-testmmap-fix-compile-issue-with-gcc-5.x.patch"
-do_fetch[depends] += "netmap-modules:do_fetch"
-
do_configure () {
cd ${S}/LINUX
./configure ${EXTRA_OECONF}