aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2021-12-27 12:38:08 -0800
committerKhem Raj <raj.khem@gmail.com>2021-12-27 14:18:40 -0800
commit2b733d2a70305904d4b04addfd4cefc2d696b761 (patch)
tree3305b4e551f49635d1fb553d687abc353bd1b91b /meta-networking
parentea76fc643713915a1618597be8bdbe0e4a3d993e (diff)
downloadmeta-openembedded-2b733d2a70305904d4b04addfd4cefc2d696b761.tar.gz
strongswan: provide PACKAGECONFIG for cureve25519
Not everyone wants this to be installed by default. Enable to remove cureve25519 is someone wants to. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb b/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb
index 45500df01c..124b5a7999 100644
--- a/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb
+++ b/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb
@@ -23,7 +23,7 @@ EXTRA_OECONF = " \
EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}"
-PACKAGECONFIG ?= "curl gmp openssl sqlite3 swanctl \
+PACKAGECONFIG ?= "curl gmp openssl sqlite3 swanctl curve25519\
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd-charon', 'charon', d)} \
"
PACKAGECONFIG[aesni] = "--enable-aesni,--disable-aesni,,${PN}-plugin-aesni"
@@ -41,6 +41,7 @@ PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4,${PN}-plugin-sou
PACKAGECONFIG[sqlite3] = "--enable-sqlite,--disable-sqlite,sqlite3,${PN}-plugin-sqlite"
PACKAGECONFIG[stroke] = "--enable-stroke,--disable-stroke,,${PN}-plugin-stroke"
PACKAGECONFIG[swanctl] = "--enable-swanctl,--disable-swanctl,,libgcc"
+PACKAGECONFIG[curve25519] = "--enable-curve25519,--disable-curve25519,, ${PN}-plugin-curve25519"
# requires swanctl
PACKAGECONFIG[systemd-charon] = "--enable-systemd,--disable-systemd,systemd,"
@@ -130,7 +131,6 @@ RDEPENDS:${PN} += "\
${PN}-plugin-x509 \
${PN}-plugin-xauth-generic \
${PN}-plugin-xcbc \
- ${PN}-plugin-curve25519 \
"
RPROVIDES:${PN} += "${PN}-systemd"