aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-12-26 14:56:38 -0800
committerKhem Raj <raj.khem@gmail.com>2022-12-27 09:55:19 -0800
commit4da7554d81e839f0c788e2c1c1eab817c02cf114 (patch)
tree054a11391fd992dfe85032830d41064dddf54e11 /meta-networking
parent3431a80bd72e8a40129d585e2761792ca54983de (diff)
downloadmeta-openembedded-4da7554d81e839f0c788e2c1c1eab817c02cf114.tar.gz
spice-gtk: Use libucontext for coroutines on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb b/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
index d654a36f48..44b42a3313 100644
--- a/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
+++ b/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
@@ -38,6 +38,7 @@ DEPENDS = " \
usbutils \
zlib \
"
+DEPENDS:append:libc-musl = " libucontext"
RDEPENDS:${PN} = "python3-pyparsing python3-six"
@@ -46,5 +47,7 @@ inherit meson pkgconfig vala gobject-introspection features_check
REQUIRED_DISTRO_FEATURES = "opengl"
EXTRA_OEMESON = "-Dpie=true -Dvapi=enabled -Dintrospection=enabled"
+EXTRA_OEMESON:append:libc-musl = " -Dcoroutine=libucontext"
+
FILES:${PN} += "${datadir}"