aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-23 22:20:53 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2017-04-25 16:10:55 -0400
commit52db0e6c052e36da05348365b953f0bdfaefd54e (patch)
treec84da46595fff0ce5b3dfbb6559fca14ccaca2bf /meta-networking
parent9c022b475e6f3555f25a0294449d912efdfbc0e3 (diff)
downloadmeta-openembedded-52db0e6c052e36da05348365b953f0bdfaefd54e.tar.gz
squid: Upgrade to 3.5.25
Add patch to fix throw() errors with gcc7 Update copyright year to 2017 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch48
-rw-r--r--meta-networking/recipes-daemons/squid/squid_3.5.25.bb (renamed from meta-networking/recipes-daemons/squid/squid_3.5.23.bb)9
2 files changed, 53 insertions, 4 deletions
diff --git a/meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch b/meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch
new file mode 100644
index 0000000000..48674c3c57
--- /dev/null
+++ b/meta-networking/recipes-daemons/squid/files/0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch
@@ -0,0 +1,48 @@
+From f9150a0dc092ab2cbd47ee428436b747dce323a9 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 23 Apr 2017 10:28:28 -0700
+Subject: [PATCH] SquidNew: use noexcept instead of throw for C++11 compilers
+
+Fixes errors with gcc7 which is more pedantic about c++11
+conformance regarding deprecated features
+
+include/SquidNew.h:21:51: error: dynamic exception specifications are deprecated in C++11
+_SQUID_EXTERNNEW_ void *operator new[] (size_t size) throw (std::bad_alloc)
+ ^~~~~
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ include/SquidNew.h | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/include/SquidNew.h b/include/SquidNew.h
+index 39fcee0..c960347 100644
+--- a/include/SquidNew.h
++++ b/include/SquidNew.h
+@@ -18,19 +18,19 @@
+ */
+ #include <new>
+
+-_SQUID_EXTERNNEW_ void *operator new(size_t size) throw (std::bad_alloc)
++_SQUID_EXTERNNEW_ void *operator new(size_t size) noexcept(false)
+ {
+ return xmalloc(size);
+ }
+-_SQUID_EXTERNNEW_ void operator delete (void *address) throw()
++_SQUID_EXTERNNEW_ void operator delete (void *address) noexcept(true)
+ {
+ xfree(address);
+ }
+-_SQUID_EXTERNNEW_ void *operator new[] (size_t size) throw (std::bad_alloc)
++_SQUID_EXTERNNEW_ void *operator new[] (size_t size) noexcept(false)
+ {
+ return xmalloc(size);
+ }
+-_SQUID_EXTERNNEW_ void operator delete[] (void *address) throw()
++_SQUID_EXTERNNEW_ void operator delete[] (void *address) noexcept(true)
+ {
+ xfree(address);
+ }
+--
+2.12.2
+
diff --git a/meta-networking/recipes-daemons/squid/squid_3.5.23.bb b/meta-networking/recipes-daemons/squid/squid_3.5.25.bb
index 0fe9673afc..5116383b87 100644
--- a/meta-networking/recipes-daemons/squid/squid_3.5.23.bb
+++ b/meta-networking/recipes-daemons/squid/squid_3.5.25.bb
@@ -21,12 +21,13 @@ SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${MIN_VER}/${BPN}-${P
file://volatiles.03_squid \
file://set_sysroot_patch.patch \
file://squid-don-t-do-squid-conf-tests-at-build-time.patch \
-"
-SRC_URI[md5sum] = "b9e5603f00b0c40109610667d8693b22"
-SRC_URI[sha256sum] = "4384564e6227fbb4c18626d663e1b47912d3507b596ed997f2149f10dd8d70bd"
+ file://0001-SquidNew-use-noexcept-instead-of-throw-for-C-11-comp.patch \
+ "
+SRC_URI[md5sum] = "c34b228129a755f363367c45c46287ba"
+SRC_URI[sha256sum] = "0bfd6182154b7f29574d71c659f1cfd1b7d9be9356895dac70dc0f3696a0639b"
LIC_FILES_CHKSUM = "file://COPYING;md5=c492e2d6d32ec5c1aad0e0609a141ce9 \
- file://errors/COPYRIGHT;md5=0d98c4448c368d146f31a970bb0ced21 \
+ file://errors/COPYRIGHT;md5=8861130fae91400bcf99b66f133172b3 \
"
DEPENDS = "libtool krb5 openldap db cyrus-sasl"