aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2022-01-14 09:39:41 +0800
committerKhem Raj <raj.khem@gmail.com>2022-01-18 09:01:51 -0800
commit57d127e81e5778ee8ab418a03f73ff277f3d1b9f (patch)
tree1eaebac8c5db739e5216c19804c3dea8ea19a58a /meta-networking
parent3b47273cedad16ccf3b5ea22bfa88b6fe85a2c13 (diff)
downloadmeta-openembedded-57d127e81e5778ee8ab418a03f73ff277f3d1b9f.tar.gz
iscsi-initiator-utils: upgrade 2.1.4. -> 2.1.5
Backport a patch to fix the build error. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Fix-compiler-error-introduced-with-recent-IPv6-commi.patch43
-rw-r--r--meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.5.bb (renamed from meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.4.bb)3
2 files changed, 45 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Fix-compiler-error-introduced-with-recent-IPv6-commi.patch b/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Fix-compiler-error-introduced-with-recent-IPv6-commi.patch
new file mode 100644
index 0000000000..ba0ca4ca0a
--- /dev/null
+++ b/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-Fix-compiler-error-introduced-with-recent-IPv6-commi.patch
@@ -0,0 +1,43 @@
+From 424d5967e94f6adf4c0669d390779af8da0bef20 Mon Sep 17 00:00:00 2001
+From: Lee Duncan <lduncan@suse.com>
+Date: Sat, 18 Sep 2021 16:10:50 -0700
+Subject: [PATCH] Fix compiler error introduced with recent IPv6 commit.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Commit 76350316de38 ("Handle IPv6 interfaces correctly.") added
+a string copy that creates this gcc-11 error message:
+
+> gcc-11 -O2 -g -Wall -Werror -Wextra -fvisibility=hidden -fPIC -I/usr/include/kmod -c -o idbm.o idbm.c
+> idbm.c: In function ‘_idbm_node_rec_link’:
+> idbm.c:999:17: error: ‘strncpy’ specified bound 65 equals destination size [-Werror=stringop-truncation]
+> 999 | strncpy((*node).iface.name, iface_name, ISCSI_MAX_IFACE_LEN);
+> | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+So copy one less character, maximum.
+
+Upstream-Status: Backport
+[https://github.com/open-iscsi/open-iscsi/commit/424d5967e94f6adf4c0669d390779af8da0bef20]
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+---
+ libopeniscsiusr/idbm.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libopeniscsiusr/idbm.c b/libopeniscsiusr/idbm.c
+index b2524ed..6f57e45 100644
+--- a/libopeniscsiusr/idbm.c
++++ b/libopeniscsiusr/idbm.c
+@@ -996,7 +996,7 @@ static void _idbm_node_rec_link(struct iscsi_node *node, struct idbm_rec *recs,
+
+ /* use the interface name passed in, if any */
+ if (iface_name)
+- strncpy((*node).iface.name, iface_name, ISCSI_MAX_IFACE_LEN);
++ strncpy((*node).iface.name, iface_name, ISCSI_MAX_IFACE_LEN-1);
+
+ /*
+ * Note: because we do not add the iface.iscsi_ifacename to
+--
+2.25.1
+
diff --git a/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.4.bb b/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.5.bb
index 034e6ee9d9..26b5b5c34b 100644
--- a/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.4.bb
+++ b/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.5.bb
@@ -12,10 +12,11 @@ DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-SRCREV ?= "095f59ca464220eae285de6b5f2ee31185a6a84c"
+SRCREV ?= "20d0aa96f2170339b1967f4be81e9c5042bbce03"
SRC_URI = "git://github.com/open-iscsi/open-iscsi;branch=master;protocol=https \
file://0001-Makefile-Do-not-set-Werror.patch \
+ file://0001-Fix-compiler-error-introduced-with-recent-IPv6-commi.patch \
file://initd.debian \
file://99_iscsi-initiator-utils \
file://iscsi-initiator \