aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-04-12 14:52:08 -0700
committerKhem Raj <raj.khem@gmail.com>2022-04-13 19:21:41 -0700
commit6f5d694d9c328a9d8e0bd927d569714cd75597b7 (patch)
tree789da2373824a997ff2f2617fd2465b5bdac105c /meta-networking
parent66fdbc25c138daf5b7190ee1a14a58f93686f9da (diff)
downloadmeta-openembedded-6f5d694d9c328a9d8e0bd927d569714cd75597b7.tar.gz
ot-br-posix: Disable Wsign-compare for clang
Specify is via CXXFLAGS instead of pragma dance. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/openthread/ot-br-posix/Turn-off-sign-compare-for-musl-libc.patch131
-rw-r--r--meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb3
2 files changed, 2 insertions, 132 deletions
diff --git a/meta-networking/recipes-connectivity/openthread/ot-br-posix/Turn-off-sign-compare-for-musl-libc.patch b/meta-networking/recipes-connectivity/openthread/ot-br-posix/Turn-off-sign-compare-for-musl-libc.patch
deleted file mode 100644
index df84550be0..0000000000
--- a/meta-networking/recipes-connectivity/openthread/ot-br-posix/Turn-off-sign-compare-for-musl-libc.patch
+++ /dev/null
@@ -1,131 +0,0 @@
-From: Stefan Schmidt <stefan.schmidt@huawei.com>
-Subject: Turn off sign compare for musl libc
-
-When building with musl and clang the usage of CMSG_NXTHDR results in
-sign-compare error. Disable the check only in this specific part of the
-code with a #pragma.
-
-| /home/stefan/huawei/yocto-upstream/yoe/workspace/sources/ot-br-posix/third_party/openthread/repo/src/posix/platform/udp.cpp:147:28: fatal error: comparison of integers of different signs: 'unsigned long' and 'long' [-Wsign-compare]
-| cmsg = CMSG_NXTHDR(&msg, cmsg);
-| ^~~~~~~~~~~~~~~~~~~~~~~
-| /home/stefan/huawei/yocto-upstream/yoe/build/tmp/work/cortexa57-yoe-linux-musl/ot-br-posix/0.3.0+git999-r0/recipe-sysroot/usr/include/sys/socket.h:358:44: note: expanded from macro 'CMSG_NXTHDR'
-| __CMSG_LEN(cmsg) + sizeof(struct cmsghdr) >= __MHDR_END(mhdr) - (unsigned char *)(cmsg) \
-| ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-| 1 error generated.
-
-Idea and fix taken from
-recipes-devtools/breakpad/breakpad/0001-Turn-off-sign-compare-for-musl-libc.patch
-by Khem Raj.
-
-Upstream-Status: Inappropriate [OE specific]
-
-Signed-off-by: Stefan Schmidt <stefan.schmidt@huawei.com>
-
-diff --git a/src/backbone_router/nd_proxy.cpp b/src/backbone_router/nd_proxy.cpp
-index 7136878c3d..8a223c95c7 100644
---- a/src/backbone_router/nd_proxy.cpp
-+++ b/src/backbone_router/nd_proxy.cpp
-@@ -185,9 +185,18 @@ void NdProxyManager::ProcessMulticastNeighborSolicition()
- VerifyOrExit(icmp6header->icmp6_type == ND_NEIGHBOR_SOLICIT, error = OTBR_ERROR_PARSE);
-
- otbrLogDebug("NdProxyManager: Received ND-NS from %s", src.ToString().c_str());
--
-+#ifndef __GLIBC__
-+ // In musl-libc, CMSG_NXTHDR typecasts char* to cmsghdr* which causes
-+ // clang to throw sign-compare warning. This is to suppress the warning
-+ // inline.
-+ #pragma clang diagnostic push
-+ #pragma clang diagnostic ignored "-Wsign-compare"
-+#endif
- for (cmsghdr = CMSG_FIRSTHDR(&msghdr); cmsghdr; cmsghdr = CMSG_NXTHDR(&msghdr, cmsghdr))
-- {
-+#ifndef __GLIBC__
-+ #pragma clang diagnostic pop
-+#endif
-+ {
- if (cmsghdr->cmsg_level != IPPROTO_IPV6)
- {
- continue;
-Submodule third_party/openthread/repo contains modified content
-diff --git a/third_party/openthread/repo/src/posix/platform/infra_if.cpp b/third_party/openthread/repo/src/posix/platform/infra_if.cpp
-index 9f93d2b1c..1ed40fe50 100644
---- a/third_party/openthread/repo/src/posix/platform/infra_if.cpp
-+++ b/third_party/openthread/repo/src/posix/platform/infra_if.cpp
-@@ -228,7 +228,17 @@ otError InfraNetif::SendIcmp6Nd(uint32_t aInfraIfIndex,
- packetInfo->ipi6_ifindex = mInfraIfIndex;
-
- // Per section 6.1.2 of RFC 4861, we need to send the ICMPv6 message with IP Hop Limit 255.
-+#ifndef __GLIBC__
-+ // In musl-libc, CMSG_NXTHDR typecasts char* to cmsghdr* which causes
-+ // clang to throw sign-compare warning. This is to suppress the warning
-+ // inline.
-+ #pragma clang diagnostic push
-+ #pragma clang diagnostic ignored "-Wsign-compare"
-+#endif
- cmsgPointer = CMSG_NXTHDR(&msgHeader, cmsgPointer);
-+#ifndef __GLIBC__
-+ #pragma clang diagnostic pop
-+#endif
- cmsgPointer->cmsg_level = IPPROTO_IPV6;
- cmsgPointer->cmsg_type = IPV6_HOPLIMIT;
- cmsgPointer->cmsg_len = CMSG_LEN(sizeof(hopLimit));
-@@ -481,7 +491,17 @@ void InfraNetif::ReceiveIcmp6Message(void)
-
- bufferLength = static_cast<uint16_t>(rval);
-
-+#ifndef __GLIBC__
-+ // In musl-libc, CMSG_NXTHDR typecasts char* to cmsghdr* which causes
-+ // clang to throw sign-compare warning. This is to suppress the warning
-+ // inline.
-+ #pragma clang diagnostic push
-+ #pragma clang diagnostic ignored "-Wsign-compare"
-+#endif
- for (cmh = CMSG_FIRSTHDR(&msg); cmh; cmh = CMSG_NXTHDR(&msg, cmh))
-+#ifndef __GLIBC__
-+ #pragma clang diagnostic pop
-+#endif
- {
- if (cmh->cmsg_level == IPPROTO_IPV6 && cmh->cmsg_type == IPV6_PKTINFO &&
- cmh->cmsg_len == CMSG_LEN(sizeof(struct in6_pktinfo)))
-diff --git a/third_party/openthread/repo/src/posix/platform/udp.cpp b/third_party/openthread/repo/src/posix/platform/udp.cpp
-index b7aacc5fa..a814fea70 100644
---- a/third_party/openthread/repo/src/posix/platform/udp.cpp
-+++ b/third_party/openthread/repo/src/posix/platform/udp.cpp
-@@ -144,8 +144,18 @@ otError transmitPacket(int aFd, uint8_t *aPayload, uint16_t aLength, const otMes
- {
- struct in6_pktinfo pktinfo;
-
-+#ifndef __GLIBC__
-+ // In musl-libc, CMSG_NXTHDR typecasts char* to cmsghdr* which causes
-+ // clang to throw sign-compare warning. This is to suppress the warning
-+ // inline.
-+ #pragma clang diagnostic push
-+ #pragma clang diagnostic ignored "-Wsign-compare"
-+#endif
- cmsg = CMSG_NXTHDR(&msg, cmsg);
-- cmsg->cmsg_level = IPPROTO_IPV6;
-+#ifndef __GLIBC__
-+ #pragma clang diagnostic pop
-+#endif
-+ cmsg->cmsg_level = IPPROTO_IPV6;
- cmsg->cmsg_type = IPV6_PKTINFO;
- cmsg->cmsg_len = CMSG_LEN(sizeof(pktinfo));
-
-@@ -200,7 +210,17 @@ otError receivePacket(int aFd, uint8_t *aPayload, uint16_t &aLength, otMessageIn
- VerifyOrExit(rval > 0, perror("recvmsg"));
- aLength = static_cast<uint16_t>(rval);
-
-+#ifndef __GLIBC__
-+ // In musl-libc, CMSG_NXTHDR typecasts char* to cmsghdr* which causes
-+ // clang to throw sign-compare warning. This is to suppress the warning
-+ // inline.
-+ #pragma clang diagnostic push
-+ #pragma clang diagnostic ignored "-Wsign-compare"
-+#endif
- for (struct cmsghdr *cmsg = CMSG_FIRSTHDR(&msg); cmsg != nullptr; cmsg = CMSG_NXTHDR(&msg, cmsg))
-+#ifndef __GLIBC__
-+ #pragma clang diagnostic pop
-+#endif
- {
- if (cmsg->cmsg_level == IPPROTO_IPV6)
- {
diff --git a/meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb b/meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb
index d9f558d792..c1af388627 100644
--- a/meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb
+++ b/meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb
@@ -16,7 +16,6 @@ PV = "0.3.0+git${SRCPV}"
SRC_URI = "gitsm://github.com/openthread/ot-br-posix.git;protocol=https;branch=main \
file://0001-otbr-agent.service.in-remove-pre-exec-hook-for-mdns-.patch \
- file://Turn-off-sign-compare-for-musl-libc.patch \
"
S = "${WORKDIR}/git"
@@ -24,6 +23,8 @@ SYSTEMD_SERVICE:${PN} = "otbr-agent.service"
inherit pkgconfig cmake systemd
+CXXFLAGS:append:libc-musl:toolchain-clang = " -Wno-error=sign-compare"
+
EXTRA_OECMAKE = "-DBUILD_TESTING=OFF \
-DOTBR_DBUS=ON \
-DOTBR_REST=ON \