aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2021-11-25 10:44:49 +0800
committerKhem Raj <raj.khem@gmail.com>2021-11-25 10:14:18 -0800
commitd3eb0a9e848cf5085c1579ec2277f546866f7f87 (patch)
tree62e5363a80ba29f9282c5791a35e3ced2b000fdc /meta-networking
parente02caef1cccaef0fe060a04699cd1adf28c5ff83 (diff)
downloadmeta-openembedded-d3eb0a9e848cf5085c1579ec2277f546866f7f87.tar.gz
samba: add pyldb to rdepends for samba-python3
Fixes: $ python3 >>> import samba Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/usr/lib64/python3.10/site-packages/samba/__init__.py", line 28, in <module> import ldb ModuleNotFoundError: No module named 'ldb' >>> Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.14.10.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.14.10.bb b/meta-networking/recipes-connectivity/samba/samba_4.14.10.bb
index af07954584..0a5dbe9c95 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.14.10.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.14.10.bb
@@ -245,7 +245,7 @@ PACKAGESPLITFUNCS:prepend = "samba_populate_packages "
PACKAGES_DYNAMIC = "samba-auth-.* samba-pdb-.*"
RDEPENDS:${PN} += "${PN}-base ${PN}-python3 ${PN}-dsdb-modules python3"
-RDEPENDS:${PN}-python3 += "pytalloc python3-tdb"
+RDEPENDS:${PN}-python3 += "pytalloc python3-tdb pyldb"
FILES:${PN}-base = "${sbindir}/nmbd \
${sbindir}/smbd \