aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorJohannes Pointner <johannes.pointner@br-automation.com>2018-02-27 08:18:43 +0100
committerJoe MacDonald <joe_macdonald@mentor.com>2018-04-06 08:12:20 -0400
commitdb4763a59186e05872b69728728bd2351a514581 (patch)
tree2d2ec18f5e269c40a6056cf505b6a93f2bbdfe8a /meta-networking
parentea5c8925c0cf1d35800547cfc5d6efc05b94d3d2 (diff)
downloadmeta-openembedded-db4763a59186e05872b69728728bd2351a514581.tar.gz
libldb: update to version 1.3.1
Version >= 1.2.3 needed to build samba 4.7.5. Signed-off-by: Johannes Pointner <johannes.pointner@br-automation.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/libldb/libldb/options-1.3.1.patch (renamed from meta-networking/recipes-support/libldb/libldb/ldb-Add-configure-options-for-packages.patch)38
-rw-r--r--meta-networking/recipes-support/libldb/libldb_1.3.1.bb (renamed from meta-networking/recipes-support/libldb/libldb_1.2.2.bb)6
2 files changed, 30 insertions, 14 deletions
diff --git a/meta-networking/recipes-support/libldb/libldb/ldb-Add-configure-options-for-packages.patch b/meta-networking/recipes-support/libldb/libldb/options-1.3.1.patch
index 93bd4578e1..ffe253b63c 100644
--- a/meta-networking/recipes-support/libldb/libldb/ldb-Add-configure-options-for-packages.patch
+++ b/meta-networking/recipes-support/libldb/libldb/options-1.3.1.patch
@@ -1,7 +1,7 @@
-From 49dde22e798fd7f39fd59250036c0ae1fe2b9152 Mon Sep 17 00:00:00 2001
+From a4da3ab4d76013aaa731d43d52ccca1ebd37c395 Mon Sep 17 00:00:00 2001
From: Jackie Huang <jackie.huang@windriver.com>
Date: Wed, 21 Sep 2016 10:06:39 +0800
-Subject: [PATCH] ldb: Add configure options for packages
+Subject: [PATCH 1/1] ldb: Add configure options for packages
Add configure options for the following packages:
- acl
@@ -16,9 +16,9 @@ Upstream-Status: Inappropriate [oe deterministic build specific]
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
---
lib/replace/system/wscript_configure | 6 ++-
- lib/replace/wscript | 85 ++++++++++++++++++++++++++++--------
+ lib/replace/wscript | 94 +++++++++++++++++++++++++++---------
wscript | 7 +++
- 3 files changed, 80 insertions(+), 18 deletions(-)
+ 3 files changed, 83 insertions(+), 24 deletions(-)
diff --git a/lib/replace/system/wscript_configure b/lib/replace/system/wscript_configure
index 2035474..10f9ae7 100644
@@ -37,7 +37,7 @@ index 2035474..10f9ae7 100644
# solaris varients of getXXent_r
diff --git a/lib/replace/wscript b/lib/replace/wscript
-index 145300d..8218fa5 100644
+index 2f94d49..68b2d3a 100644
--- a/lib/replace/wscript
+++ b/lib/replace/wscript
@@ -23,6 +23,41 @@ def set_options(opt):
@@ -124,18 +124,23 @@ index 145300d..8218fa5 100644
conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h')
conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h')
conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h')
-@@ -248,17 +298,18 @@ def configure(conf):
+@@ -266,22 +316,20 @@ def configure(conf):
conf.CHECK_FUNCS('prctl dirname basename')
+- strlcpy_in_bsd = False
+-
- # libbsd on some platforms provides strlcpy and strlcat
- if not conf.CHECK_FUNCS('strlcpy strlcat'):
-- conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
-- checklibc=True)
+- if conf.CHECK_FUNCS_IN('strlcpy strlcat', 'bsd', headers='bsd/string.h',
+- checklibc=True):
+- strlcpy_in_bsd = True
- if not conf.CHECK_FUNCS('getpeereid'):
- conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
- if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'):
- conf.CHECK_FUNCS_IN('setproctitle', 'bsd', headers='sys/types.h bsd/unistd.h')
+- if not conf.CHECK_FUNCS('setproctitle_init'):
+- conf.CHECK_FUNCS_IN('setproctitle_init', 'bsd', headers='sys/types.h bsd/unistd.h')
-
- if not conf.CHECK_FUNCS('closefrom'):
- conf.CHECK_FUNCS_IN('closefrom', 'bsd', headers='bsd/unistd.h')
@@ -148,17 +153,28 @@ index 145300d..8218fa5 100644
+ conf.CHECK_FUNCS_IN('getpeereid', 'bsd', headers='sys/types.h bsd/unistd.h')
+ if not conf.CHECK_FUNCS_IN('setproctitle', 'setproctitle', headers='setproctitle.h'):
+ conf.CHECK_FUNCS_IN('setproctitle', 'bsd', headers='sys/types.h bsd/unistd.h')
++ if not conf.CHECK_FUNCS('setproctitle_init'):
++ conf.CHECK_FUNCS_IN('setproctitle_init', 'bsd', headers='sys/types.h bsd/unistd.h')
+
+ if not conf.CHECK_FUNCS('closefrom'):
+ conf.CHECK_FUNCS_IN('closefrom', 'bsd', headers='bsd/unistd.h')
conf.CHECK_CODE('''
struct ucred cred;
+@@ -632,7 +680,7 @@ removeea setea
+ # look for a method of finding the list of network interfaces
+ for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']:
+ bsd_for_strlcpy = ''
+- if strlcpy_in_bsd:
++ if Options.options.enable_libbsd:
+ bsd_for_strlcpy = ' bsd'
+ if conf.CHECK_CODE('''
+ #define %s 1
diff --git a/wscript b/wscript
-index 2af8571..059408b 100755
+index 8ae5be3..a178cc4 100644
--- a/wscript
+++ b/wscript
-@@ -29,6 +29,13 @@ def set_options(opt):
+@@ -31,6 +31,13 @@ def set_options(opt):
opt.RECURSE('lib/replace')
opt.tool_options('python') # options for disabling pyc or pyo compilation
@@ -173,5 +189,5 @@ index 2af8571..059408b 100755
conf.RECURSE('lib/tdb')
conf.RECURSE('lib/tevent')
--
-2.8.3
+2.16.2
diff --git a/meta-networking/recipes-support/libldb/libldb_1.2.2.bb b/meta-networking/recipes-support/libldb/libldb_1.3.1.bb
index cb9ea92838..7e14cde35f 100644
--- a/meta-networking/recipes-support/libldb/libldb_1.2.2.bb
+++ b/meta-networking/recipes-support/libldb/libldb_1.3.1.bb
@@ -8,7 +8,7 @@ RDEPENDS_pyldb += "python"
SRC_URI = "http://samba.org/ftp/ldb/ldb-${PV}.tar.gz \
file://do-not-import-target-module-while-cross-compile.patch \
- file://ldb-Add-configure-options-for-packages.patch \
+ file://options-1.3.1.patch \
"
PACKAGECONFIG ??= "\
@@ -29,8 +29,8 @@ LIC_FILES_CHKSUM = "file://pyldb.h;endline=24;md5=dfbd238cecad76957f7f860fbe9ada
file://man/ldb.3.xml;beginline=261;endline=262;md5=137f9fd61040c1505d1aa1019663fd08 \
file://tools/ldbdump.c;endline=19;md5=a7d4fc5d1f75676b49df491575a86a42"
-SRC_URI[md5sum] = "91284a12423def99a6592e393e3b7fbb"
-SRC_URI[sha256sum] = "0cedeadb75de401c9735127f654dbc1a391c4327a2b83be54078be286fed1113"
+SRC_URI[md5sum] = "e5233f202bca27f6ce8474fb8ae65983"
+SRC_URI[sha256sum] = "b19f2c9f55ae0f46aa5ebaea0bf1a47ec1ac135e1d78af0f6318cf50bf62cbd2"
inherit waf-samba