aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2022-12-09 18:05:04 +0800
committerKhem Raj <raj.khem@gmail.com>2022-12-09 10:39:27 -0800
commite5e37cc656fc044b8ec9059eee8ae9b6617fcd9c (patch)
treeee8f8e42d8f937d26698259974a9772ab0f9fa96 /meta-networking
parent6746c04f85c734c3323d3e579592f3c4493abd7e (diff)
downloadmeta-openembedded-e5e37cc656fc044b8ec9059eee8ae9b6617fcd9c.tar.gz
spice-gtk: add opengl to REQUIRED_DISTRO_FEATURES
Fixes: ERROR: Nothing PROVIDES 'libepoxy' (but /build/layers/meta-openembedded/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb DEPENDS on or otherwise requires it) libepoxy was skipped: missing required distro feature 'opengl' (not in DISTRO_FEATURES) ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'spice-gtk', 'libepoxy'] Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb b/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
index a6130cab34..d654a36f48 100644
--- a/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
+++ b/meta-networking/recipes-support/spice/spice-gtk_0.4.1.bb
@@ -41,7 +41,9 @@ DEPENDS = " \
RDEPENDS:${PN} = "python3-pyparsing python3-six"
-inherit meson pkgconfig vala gobject-introspection
+inherit meson pkgconfig vala gobject-introspection features_check
+
+REQUIRED_DISTRO_FEATURES = "opengl"
EXTRA_OEMESON = "-Dpie=true -Dvapi=enabled -Dintrospection=enabled"