aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/classes
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/classes
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/classes')
-rw-r--r--meta-oe/classes/gpe.bbclass4
-rw-r--r--meta-oe/classes/vala.bbclass6
2 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/classes/gpe.bbclass b/meta-oe/classes/gpe.bbclass
index 7e042ee930..2adbd48419 100644
--- a/meta-oe/classes/gpe.bbclass
+++ b/meta-oe/classes/gpe.bbclass
@@ -7,11 +7,11 @@ SECTION ?= "gpe"
inherit gettext
gpe_do_compile() {
- oe_runmake PREFIX=${prefix}
+ oe_runmake PREFIX=${prefix}
}
gpe_do_install() {
- oe_runmake PREFIX=${prefix} DESTDIR=${D} install
+ oe_runmake PREFIX=${prefix} DESTDIR=${D} install
}
EXPORT_FUNCTIONS do_compile do_install
diff --git a/meta-oe/classes/vala.bbclass b/meta-oe/classes/vala.bbclass
index d4ba83193a..c7db08ceeb 100644
--- a/meta-oe/classes/vala.bbclass
+++ b/meta-oe/classes/vala.bbclass
@@ -12,7 +12,7 @@ export XDG_DATA_DIRS = "${STAGING_DATADIR}"
# Package additional files
FILES_${PN}-dev += "\
- ${datadir}/vala/vapi/*.vapi \
- ${datadir}/vala/vapi/*.deps \
- ${datadir}/gir-1.0 \
+ ${datadir}/vala/vapi/*.vapi \
+ ${datadir}/vala/vapi/*.deps \
+ ${datadir}/gir-1.0 \
"