aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-09-16 14:19:14 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-26 08:29:10 +0200
commit0d103ba6b8156acfa70b74060b93eb263dfbb5ee (patch)
tree779d4038e9945d81c797161c85cb7a9e0906d379 /meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb
parentdd01b4bdecc0958bac0d8d908f861d412d6294ac (diff)
downloadmeta-openembedded-0d103ba6b8156acfa70b74060b93eb263dfbb5ee.tar.gz
pointercal: move recipe from oe-core
Move pointercal recipe from oe-core layer. Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb')
-rw-r--r--meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb b/meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb
new file mode 100644
index 0000000000..fcfd0386d9
--- /dev/null
+++ b/meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Touchscreen calibration data"
+SECTION = "base"
+PR = "r11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4b5fcfc87fb615860d398b5e38685edf"
+
+SRC_URI = "file://pointercal \
+ file://COPYING"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # Only install file if it has a contents
+ if [ -s ${S}/pointercal ]; then
+ install -d ${D}${sysconfdir}/
+ install -m 0644 ${S}/pointercal ${D}${sysconfdir}/
+ fi
+}
+
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+INHIBIT_DEFAULT_DEPS = "1"