aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-10-09 06:21:49 -0700
committerKhem Raj <raj.khem@gmail.com>2019-10-09 23:27:15 -0700
commit329554e01f68863a0ebb21b2d81d726c94753e68 (patch)
treea75345c9cf3bf354d388845d8479c0eb7841591f /meta-oe/recipes-bsp
parent01b55a8a552d460acbe3673268733a78b47c5c03 (diff)
downloadmeta-openembedded-329554e01f68863a0ebb21b2d81d726c94753e68.tar.gz
nvme-cli: Use install-spec target
install target build install-hostparams as well, which tries to run nvme tool during build, we defer that to runtime post_install anyway so we can ignore building it during install task package systemd unit files Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r--meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.9.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.9.bb b/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.9.bb
index 256d83f039..6133b3a270 100644
--- a/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.9.bb
+++ b/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.9.bb
@@ -15,7 +15,7 @@ S = "${WORKDIR}/git"
inherit bash-completion systemd
do_install() {
- oe_runmake install DESTDIR=${D} PREFIX=${prefix} \
+ oe_runmake install-spec DESTDIR=${D} PREFIX=${prefix} \
UDEVDIR=${nonarch_base_libdir}/udev SYSTEMDDIR=${systemd_unitdir}
}
@@ -25,5 +25,6 @@ pkg_postinst_ontarget_${PN}() {
PACKAGES =+ "${PN}-dracut ${PN}-zsh-completion"
+FILES_${PN} += "${systemd_system_unitdir}"
FILES_${PN}-dracut = "${libdir}/dracut/dracut.conf.d"
FILES_${PN}-zsh-completion = "${datadir}/zsh/site-functions"