aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2020-03-11 16:42:05 +0800
committerKhem Raj <raj.khem@gmail.com>2020-03-11 08:58:57 -0700
commitd178745cbf5c97b7cdcf274108a58c8e1f88d3ca (patch)
treeab1cf2f60e724eeecbfbf4a6c1973c4b5fee2c65 /meta-oe/recipes-bsp
parentf5d2bf55a8169a9446c2f96f327b3e5d91a6e6cc (diff)
downloadmeta-openembedded-d178745cbf5c97b7cdcf274108a58c8e1f88d3ca.tar.gz
conf/layer.conf: add BBFILES_DYNAMIC and dynamic layers
some recipes under meta-oe have dependency on meta-python, and test_world of yocto-check-layer will failed with error like: ERROR: test_world (common.CommonCheckLayer) ERROR: Nothing PROVIDES 'python3-pytoml-native' (but /meta-openembedded/meta-oe/recipes-extended/mozjs/mozjs_60.9.0.bb DEPENDS on or otherwise requires it). Close matches: python3-numpy-native python3-pycairo-native python3-rpm-native ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'mozjs', 'python3-pytoml-native'] fix by make these recipes only active when identified layers are present Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r--meta-oe/recipes-bsp/rwmem/rwmem_1.2.bb35
1 files changed, 0 insertions, 35 deletions
diff --git a/meta-oe/recipes-bsp/rwmem/rwmem_1.2.bb b/meta-oe/recipes-bsp/rwmem/rwmem_1.2.bb
deleted file mode 100644
index 065243ccfe..0000000000
--- a/meta-oe/recipes-bsp/rwmem/rwmem_1.2.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-SUMMARY = "A small tool to read/write memory"
-DESCRIPTION = "rwmem is a small tool for reading and writing device registers. \
-rwmem supports two modes: mmap mode and i2c mode. \
-\
-In mmap mode rwmem accesses a file by memory mapping it. \
-Using /dev/mem as the memory mapped file makes rwmem access memory and \
-can thus be used to access devices which have memory mapped registers. \
-\
-In i2c mode rwmem accesses an i2c peripheral by sending i2c messages to it."
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-
-DEPENDS += "python3 python3-pybind11"
-
-PV .= "+git${SRCPV}"
-
-SRCREV_rwmem = "3ec3e421211b58e766651c2e3a3a21acf14a1906"
-SRCREV_inih = "4b10c654051a86556dfdb634c891b6c3224c4109"
-
-SRCREV_FORMAT = "rwmem_inih"
-
-SRC_URI = " \
- git://github.com/tomba/rwmem.git;protocol=https;name=rwmem \
- git://github.com/benhoyt/inih.git;protocol=https;name=inih;nobranch=1;destsuffix=git/ext/inih \
-"
-
-S = "${WORKDIR}/git"
-
-inherit cmake pkgconfig
-
-do_install() {
- install -D -m 0755 ${B}/bin/rwmem ${D}${bindir}/rwmem
- install -D -m 0644 ${B}/lib/librwmem.a ${D}${libdir}/librwmem.a
-}