aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2014-07-01 14:40:42 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-15 15:02:28 +0200
commit31f6f1aa6c6a9a762213435121408a2303b9ce63 (patch)
tree5be1d4aa985ffb56d2b541ca6b0f8a2b2ae16b96 /meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb
parent6006202cde7956b280dfa2cfec7b6d928aea3f1c (diff)
downloadmeta-openembedded-31f6f1aa6c6a9a762213435121408a2303b9ce63.tar.gz
hostapd: uprev to 2.2
Rename hostap-daemon as hostapd and uprev it to 2.2 Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb')
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb b/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb
new file mode 100644
index 0000000000..d0d9df986d
--- /dev/null
+++ b/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb
@@ -0,0 +1,43 @@
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+LICENSE = "GPLv2 | BSD"
+LIC_FILES_CHKSUM = "file://README;md5=0854a4da34ac3990770794d771fac7fd"
+DEPENDS = "libnl openssl"
+SUMMARY = "User space daemon for extended IEEE 802.11 management"
+
+inherit update-rc.d
+INITSCRIPT_NAME = "hostapd"
+
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = " \
+ http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
+ file://defconfig \
+ file://init \
+"
+
+S = "${WORKDIR}/hostapd-${PV}/hostapd"
+
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}
+
+do_compile() {
+ export CFLAGS="-MMD -O2 -Wall -g -I${STAGING_INCDIR}/libnl3"
+ make
+}
+
+do_install() {
+ install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
+ install -m 0644 ${S}/hostapd.conf ${D}${sysconfdir}
+ install -m 0755 ${S}/hostapd ${D}${sbindir}
+ install -m 0755 ${S}/hostapd_cli ${D}${sbindir}
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
+}
+
+CONFFILES_${PN} += "${sysconfdir}/hostapd.conf"
+
+SRC_URI[md5sum] = "23c1f78a693c3288802d516adb7fd289"
+SRC_URI[sha256sum] = "f15b6bcb434378860ea5b88dffed7f54d8cb71fff2146de0f006977a5e25a882"