aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/libnet
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2011-04-20 16:57:29 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-04-20 11:12:53 +0200
commitd8c4045ee190066e6fa8490bfddec6c4ca1b8c6a (patch)
tree14baec5fe345d4837d9d792363220432bfc64c97 /meta-oe/recipes-connectivity/libnet
parent358c5d0f0f35f87e51d7a2356b161f09824e16a8 (diff)
downloadmeta-openembedded-d8c4045ee190066e6fa8490bfddec6c4ca1b8c6a.tar.gz
libnet: Clean and upgrade (see below)
* libbnet upstream on packetfactor is dead using https://github.com/sam-github/libnet instead * Move to version 1.1.5 * Dropped patches (not needed): support-uclibc, new-autotools * Added LIC_FILES_CHKSUM * Removed useless do_install_append, works automatically * Not building statically anymore * Should be compatible with old v1.1 versions Signed-off-by: Michael Lippautz <michael.lippautz@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/libnet')
-rw-r--r--meta-oe/recipes-connectivity/libnet/libnet-1.1.5/fix-endianess-test.patch38
-rw-r--r--meta-oe/recipes-connectivity/libnet/libnet_1.1.5.bb24
2 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/libnet/libnet-1.1.5/fix-endianess-test.patch b/meta-oe/recipes-connectivity/libnet/libnet-1.1.5/fix-endianess-test.patch
new file mode 100644
index 0000000000..4d8697d5f9
--- /dev/null
+++ b/meta-oe/recipes-connectivity/libnet/libnet-1.1.5/fix-endianess-test.patch
@@ -0,0 +1,38 @@
+Use autoconf's endian check instead of the locally defined check
+so that we can determine the endianess without having to compile
+a program.
+
+Idea from http://www.security-lists.org/lists/libnet/2003/03/00001.html
+
+Also remove the old test from aclocal.m4.
+
+Rebased for libnet-1.1.5 on 2011/04/19.
+
+--- a/configure.in 2010-11-03 00:59:21.000000000 +0100
++++ b/configure.in 2011-04-19 17:08:47.087712604 +0200
+@@ -6,6 +6,7 @@
+ dnl
+ dnl Process this file with autoconf to produce a configure script.
+
++AC_PREREQ(2.52)
+ AC_INIT(libnet, 1.1.5)
+ AC_MSG_RESULT(beginning autoconfiguration process for libnet-${PACKAGE_VERSION} ...)
+ AC_CANONICAL_SYSTEM
+@@ -39,7 +40,16 @@
+ dnl And some custom things
+ dnl
+
+-AC_LIBNET_ENDIAN_CHECK
++AC_C_BIGENDIAN([
++ AC_DEFINE(LIBNET_BIG_ENDIAN)
++ ENDIANESS="LIBNET_BIG_ENDIAN"
++ LIBNET_CONFIG_DEFINES="$LIBNET_CONFIG_DEFINES -DLIBNET_BIG_ENDIAN"
++],[
++ AC_DEFINE(LIBNET_LIL_ENDIAN)
++ ENDIANESS="LIBNET_LIL_ENDIAN"
++ LIBNET_CONFIG_DEFINES="$LIBNET_CONFIG_DEFINES -DLIBNET_LIL_ENDIAN"
++], AC_MSG_WARN(cannot detect endianess. try setting ac_cv_c_bigendian to yes or no))
++
+ dnl AC_LBL_LIBRARY_NET
+
+ AC_SUBST(ENDIANESS)
diff --git a/meta-oe/recipes-connectivity/libnet/libnet_1.1.5.bb b/meta-oe/recipes-connectivity/libnet/libnet_1.1.5.bb
new file mode 100644
index 0000000000..ec426a552f
--- /dev/null
+++ b/meta-oe/recipes-connectivity/libnet/libnet_1.1.5.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A packet dissection and creation library"
+# libnet at packetfactory.net is dead
+HOMEPAGE = "https://github.com/sam-github/libnet"
+SECTION = "libs"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://README;md5=533bea47338d490e86744c6a0c5692e7"
+DEPENDS = "libpcap"
+# There are major API changes beween libnet v1.0 and libnet v1.1
+PROVIDES = "libnet-1.1"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libnet-dev/${PN}-${PV}.tar.gz \
+ file://fix-endianess-test.patch"
+
+SRC_URI[md5sum] = "a9bc1d75a610efcfee200d3e28d8eb8f"
+SRC_URI[sha256sum] = "75588f8d1232e1df34eccf2dba5e66be197b345a07fae80d8275db994496a20d"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit autotools binconfig
+
+do_configure_prepend() {
+ rm -f aclocal.m4 Makefile.am ltmain.sh
+}