aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/mosh
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-07-12 10:47:21 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2013-07-24 14:30:16 +0200
commit957eef8f929295967cf19b6e269a32daa7ba8043 (patch)
tree1250c3f66ff4f9eaf757dd2159705b9b2dd60f9c /meta-oe/recipes-connectivity/mosh
parent7785873f736a4443b171100e42520c7aad96d348 (diff)
downloadmeta-openembedded-957eef8f929295967cf19b6e269a32daa7ba8043.tar.gz
mosh: add new recipe for version 1.2.4
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/mosh')
-rw-r--r--meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb b/meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb
new file mode 100644
index 0000000000..c0d03c52f9
--- /dev/null
+++ b/meta-oe/recipes-connectivity/mosh/mosh_1.2.4.bb
@@ -0,0 +1,31 @@
+# NOTE: mosh-server requires a UTF-8 locale, but there's no way to add
+# an explicit dependency for this so you need to ensure this is in your
+# image yourself when you install mosh-server.
+
+SUMMARY = "Remote shell supporting roaming and high-latency connections"
+DESCRIPTION = "Remote terminal application that allows roaming, supports \
+intermittent connectivity, and provides intelligent local echo and line \
+editing of user keystrokes. Mosh is a replacement for SSH. It's more \
+robust and responsive, especially over Wi-Fi, cellular, and \
+long-distance links."
+HOMEPAGE = "http://mosh.mit.edu"
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+DEPENDS = "protobuf-native protobuf ncurses zlib libio-pty-perl openssl"
+
+SRC_URI = "http://mosh.mit.edu/mosh-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "c2d918f4d91fdc32546e2e089f9281b2"
+SRC_URI[sha256sum] = "e74d0d323226046e402dd469a176075fc2013b69b0e67cea49762c957175df46"
+
+inherit autotools
+
+PACKAGE_BEFORE_PN += "${PN}-server"
+FILES_${PN}-server = "${bindir}/mosh-server"
+
+# mosh uses SSH to authenticate and the client uses OpenSSH-specific features
+RDEPENDS_${PN} += "openssh-ssh"
+# The server seemed not to work with dropbear either
+RDEPENDS_${PN}-server += "openssh-sshd"
+