aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/obex/openobex_1.7.2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-11-28 13:07:43 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-02 09:26:19 +0100
commit0288b204f3c12af1561218fa0cfcdfb9a5508b47 (patch)
tree2ed29173d90350223cf10172a17e40646b29d2ac /meta-oe/recipes-connectivity/obex/openobex_1.7.2.bb
parentc476219e845934f767927e81fe60dbaa157df9ee (diff)
downloadmeta-openembedded-0288b204f3c12af1561218fa0cfcdfb9a5508b47.tar.gz
openobex,obexftp: Update recipes
Update obexftp to 0.24.2 and openobex to 1.7.2 These packages moved to CMake infra for builds therefore make adjustments to cross compile it Add packageconfig options for fuse and swig Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/obex/openobex_1.7.2.bb')
-rw-r--r--meta-oe/recipes-connectivity/obex/openobex_1.7.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/obex/openobex_1.7.2.bb b/meta-oe/recipes-connectivity/obex/openobex_1.7.2.bb
new file mode 100644
index 0000000000..053c80a84f
--- /dev/null
+++ b/meta-oe/recipes-connectivity/obex/openobex_1.7.2.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "The Openobex project is an open source implementation of the \
+Object Exchange (OBEX) protocol."
+HOMEPAGE = "http://openobex.triq.net"
+SECTION = "libs"
+DEPENDS = "virtual/libusb0"
+DEPENDS_append_class-target = " ${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}"
+
+LICENSE = "GPLv2 & LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
+ file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
+"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}/${PV}/${BP}-Source.tar.gz \
+"
+
+SRC_URI[md5sum] = "f6e0b6cb7dcfd731460a7e9a91429a3a"
+SRC_URI[sha256sum] = "158860aaea52f0fce0c8e4b64550daaae06df2689e05834697b7e8c7d73dd4fc"
+
+inherit cmake pkgconfig
+
+S = "${WORKDIR}/${BP}-Source"
+
+EXTRA_OECONF = " -DCMAKE_SKIP_RPATH=ON "
+
+#--enable-apps --enable-syslog
+
+do_install_append () {
+ rmdir ${D}${bindir}
+}
+
+PACKAGES =+ "openobex-apps"
+FILES_${PN}-apps = "${bindir}/*"
+FILES_${PN} += "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/openobex-config ${libdir}/cmake"
+DEBIAN_NOAUTONAME_${PN}-apps = "1"
+
+BBCLASSEXTEND = "native"