aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-06-10 21:46:50 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-16 09:39:06 +0200
commit365d5ec941347f54744b9f5fbb7b06cc3949e14a (patch)
tree322e21d7d6a98669598f40d51f89e4d8e048c273 /meta-oe/recipes-connectivity
parenta55a93180733f769d676d9e66f74bf10d5da6ff0 (diff)
downloadmeta-openembedded-365d5ec941347f54744b9f5fbb7b06cc3949e14a.tar.gz
gateone: move systemd support to meta-systemd
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone/gateone.service10
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone_git.bb9
2 files changed, 2 insertions, 17 deletions
diff --git a/meta-oe/recipes-connectivity/gateone/gateone/gateone.service b/meta-oe/recipes-connectivity/gateone/gateone/gateone.service
deleted file mode 100644
index 7ff60020a0..0000000000
--- a/meta-oe/recipes-connectivity/gateone/gateone/gateone.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=GateOne daemon
-ConditionPathExists=|/var/lib/gateone
-
-[Service]
-WorkingDirectory=/var/lib/gateone
-ExecStart=/usr/bin/python gateone.py
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
index 12f4e5107a..f6aa3776d6 100644
--- a/meta-oe/recipes-connectivity/gateone/gateone_git.bb
+++ b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
@@ -2,19 +2,18 @@ DESCRIPTION = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
LICENSE = "AGPLv3"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ee5b168fc7de89a0cadc49e27830aa2c"
-PR = "r7"
+PR = "r8"
PV = "1.1"
SRCREV = "bb74e1095adb66b04b51ed6ff10ae0aa96afdd46"
SRC_URI = "git://github.com/liftoff/GateOne.git \
file://gateone-avahi.service \
- file://gateone.service \
file://server.conf \
"
S = "${WORKDIR}/git"
-inherit distutils allarch systemd
+inherit distutils allarch
export prefix = "${localstatedir}/lib"
@@ -27,10 +26,6 @@ do_install_append() {
install -m 0644 ${WORKDIR}/server.conf ${D}/var/lib/gateone/server.conf
}
-NATIVE_SYSTEMD_SUPPORT = "1"
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE = "gateone.service"
-
FILES_${PN} = "${localstatedir}/lib ${localstatedir}/log ${base_libdir} ${sysconfdir}"
RDEPENDS_${PN} = "file \
mime-support \