aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-04-18 06:39:37 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-19 02:45:28 +0200
commit9955ac116e1f57de4c1fb01a0fa47e9591db1d4a (patch)
tree127123048e2f57f027e4175f32f301ccdf18879c /meta-oe/recipes-connectivity
parent73a17ee018a2d26584b3c1b7d4fa4b9906d14b2a (diff)
downloadmeta-openembedded-9955ac116e1f57de4c1fb01a0fa47e9591db1d4a.tar.gz
cherokee: move to meta-webserver and tweak
* Set SUMMARY instead of DESCRIPTION Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.init32
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb56
2 files changed, 0 insertions, 88 deletions
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.init b/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.init
deleted file mode 100644
index 93603b84db..0000000000
--- a/meta-oe/recipes-connectivity/cherokee/cherokee/cherokee.init
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/bin/sh
-DAEMON=/usr/sbin/cherokee
-CONFIG=/etc/cherokee/cherokee.conf
-PIDFILE=/var/run/cherokee.pid
-NAME="cherokee"
-DESC="Cherokee http server"
-
-test -r /etc/default/cherokee && . /etc/default/cherokee
-test -x "$DAEMON" || exit 0
-test ! -r "$CONFIG" && exit 0
-
-case "$1" in
- start)
- echo "Starting $DESC: "
- start-stop-daemon --oknodo -S -x $DAEMON -- -d -C $CONFIG
- ;;
-
- stop)
- echo "Stopping $DESC:"
- start-stop-daemon -K -p $PIDFILE
- ;;
-
- restart)
- $0 stop >/dev/null 2>&1
- $0 start
- ;;
-
- *)
- echo "Usage: $0 {start|stop|restart}"
- exit 0
- ;;
-esac
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
deleted file mode 100644
index 6c030a635d..0000000000
--- a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
+++ /dev/null
@@ -1,56 +0,0 @@
-DESCRIPTION = "Cherokee Web Server fast and secure"
-DESCRIPTION_cget = "Small downloader based in the Cherokee client library"
-HOMEPAGE = "http://www.cherokee-project.com/"
-SECTION = "network"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-
-PR = "r9"
-
-DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
-
-SRC_URI = "http://www.cherokee-project.com/download/1.2/${PV}/cherokee-${PV}.tar.gz \
- file://cherokee.init \
- file://cherokee.service \
-"
-SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb"
-SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d"
-
-inherit autotools pkgconfig binconfig update-rc.d systemd
-
-EXTRA_OECONF = "--disable-static \
- --disable-nls \
- ${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \
-"
-
-do_install_append () {
- install -m 0755 -d ${D}${sysconfdir}/init.d
- install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee
-
- # clean up .la files for plugins
- rm -f ${D}${libdir}/cherokee/*.la
-
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system
-}
-
-# Put -dev near the front so we can move the .la files into it with a wildcard
-PACKAGES =+ "libcherokee-server libcherokee-client libcherokee-base cget"
-
-FILES_cget = "${bindir}/cget"
-FILES_libcherokee-server = "${libdir}/libcherokee-server${SOLIBS}"
-FILES_libcherokee-client = "${libdir}/libcherokee-client${SOLIBS}"
-FILES_libcherokee-base = "${libdir}/libcherokee-base${SOLIBS}"
-
-CONFFILES_${PN} = " \
- ${sysconfdir}/cherokee/cherokee.conf \
- ${sysconfdir}/init.d/cherokee \
-"
-
-INITSCRIPT_NAME = "cherokee"
-INITSCRIPT_PARAMS = "defaults 91 91"
-
-RPROVIDES_${PN} += "${PN}-systemd"
-RREPLACES_${PN} += "${PN}-systemd"
-RCONFLICTS_${PN} += "${PN}-systemd"
-SYSTEMD_SERVICE_${PN} = "cherokee.service"