aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-06-19 08:36:19 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-06-20 13:33:24 +0200
commitb84f1a473856e8560761e1e3f045f805a7fe9362 (patch)
tree63d6b232a6b58ca9905d58e46da4da16362cfc56 /meta-oe/recipes-connectivity
parente77e933724552b5a31fd7451929cd7115500312d (diff)
downloadmeta-openembedded-b84f1a473856e8560761e1e3f045f805a7fe9362.tar.gz
rfkill: use update-alternatives
* Since oe-core added rfkill to busybox, this recipe needs to use u-a also. * MJ: added ALERNATIVE_LINK_NAME[rfkill] * MJ: increased ALTERNATIVE_PRIORITY (busybox also have 50) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb b/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb
index 561fdc7a90..430cf65bfc 100644
--- a/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb
+++ b/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb
@@ -3,6 +3,7 @@ HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/rfkill"
SECTION = "base"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=c6036d0eb7edbfced28c4160e5d3fa94"
+PR = "r1"
SRC_URI = "http://wireless.kernel.org/download/${PN}/${P}.tar.bz2 \
file://0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch"
@@ -16,3 +17,10 @@ do_compile() {
do_install() {
oe_runmake DESTDIR=${D} install
}
+
+inherit update-alternatives
+
+ALTERNATIVE_${PN} = "rfkill"
+ALTERNATIVE_PRIORITY = "60"
+ALTERNATIVE_LINK_NAME[rfkill] = "${sbindir}/rfkill"
+