aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/llvm/llvm-common.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 17:16:29 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-19 02:45:27 +0200
commit334f77d5879babebabc07b5cf7ad99127a41880d (patch)
tree3ea81497ead7d876f607123f7f9064ee136e227d /meta-oe/recipes-core/llvm/llvm-common.bb
parentbea2397361da080df1256046b927b454e2e5fc9a (diff)
downloadmeta-openembedded-334f77d5879babebabc07b5cf7ad99127a41880d.tar.gz
llvm2.8: Import from meta-java
* llvm is generic enough to be useful outside meta-java e.g. we need it to enable llvmpipe galium driver in mesa * imported without any modification (except indentation), all credits go to Henning Heinold and Khem Raj for maintaining it in meta-java Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core/llvm/llvm-common.bb')
-rw-r--r--meta-oe/recipes-core/llvm/llvm-common.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/llvm/llvm-common.bb b/meta-oe/recipes-core/llvm/llvm-common.bb
new file mode 100644
index 0000000000..612fd34f77
--- /dev/null
+++ b/meta-oe/recipes-core/llvm/llvm-common.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Helper script for OE's llvm support"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \
+"
+
+SRC_URI = "file://llvm-config"
+
+do_install() {
+ install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
+ install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
+}
+
+do_install_virtclass-native() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
+}
+
+BBCLASSEXTEND = "native"