aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-19 16:01:52 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-26 10:00:32 +0200
commit9d68ba4fc2b2f862bfb9619f74e082c88ab68604 (patch)
treee3e3d77d84dbf5d46f5640ddbd3be1392d156f66 /meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
parent87ccfd07de099ec1c95e67b72aa18e2effb77b58 (diff)
downloadmeta-openembedded-9d68ba4fc2b2f862bfb9619f74e082c88ab68604.tar.gz
llvm2.9: try to fix thumb build and disable it after failure
* khem: could you check what I'm doing wrong? This is out of my league.. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core/llvm/llvm2.9_2.9.bb')
-rw-r--r--meta-oe/recipes-core/llvm/llvm2.9_2.9.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb b/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
index d5b8c01492..dc7f873bda 100644
--- a/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
+++ b/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
@@ -4,6 +4,15 @@ PR = "${INC_PR}.0"
SRC_URI += "file://0035-gcc-4.7.patch"
+# 0019-issue6065.patch is still needed but a bit modified, because it was resolved by
+# http://llvm.org/viewvc/llvm-project/llvm/trunk/lib/Target/ARM/ARMJITInfo.cpp?r1=120304&r2=124694&pathrev=124694
+# http://llvm.org/viewvc/llvm-project/llvm/trunk/lib/Target/ARM/ARMJITInfo.cpp?diff_format=h&r1=57911&r2=57910&pathrev=57911
+# and still it fails with
+# {standard input}:31: Error: invalid register list to push/pop instruction -- `pop {r0,r1,r2,r3,lr}'
+# make[2]: *** [lib/Target/ARM/CMakeFiles/LLVMARMCodeGen.dir/ARMJITInfo.cpp.o] Error 1
+# SRC_URI += "file://0019-issue6065.patch"
+ARM_INSTRUCTION_SET = "arm"
+
SRC_URI_append_libc-uclibc = " file://arm_fenv_uclibc.patch "
PARALLEL_MAKE_virtclass-native = ""