aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/packagegroups
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-core/packagegroups
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/packagegroups')
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-basic.bb32
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-boot.bb4
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb52
3 files changed, 44 insertions, 44 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb b/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb
index 402579c6de..c100b79e07 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb
@@ -35,9 +35,9 @@ RCONFLICTS_${PN} += "task-basic"
# Util-linux (u)mount is included because the busybox one can't handle /etc/mtab being symlinked to /proc/mounts
#
RDEPENDS_${PN} = "\
- ${TASK_BASIC_SSHDAEMON} \
- avahi-daemon avahi-utils \
- "
+ ${TASK_BASIC_SSHDAEMON} \
+ avahi-daemon avahi-utils \
+"
#
# The following section is split in 3:
@@ -46,16 +46,16 @@ RDEPENDS_${PN} = "\
# 3) Nice to have: packages that are nice to have, but aren't strictly needed
#
RRECOMMENDS_${PN} = "\
- ${MACHINE_EXTRA_RRECOMMENDS} \
- ${@base_contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \
- ${@base_contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \
- ${@base_contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \
- \
- ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4", "", d)} \
- ${@base_contains("DISTRO_FEATURES", "wifi", "iw wpa-supplicant", "", d)} \
- \
- tzdata \
- \
- cpufrequtils \
- htop \
- "
+ ${MACHINE_EXTRA_RRECOMMENDS} \
+ ${@base_contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \
+ ${@base_contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \
+ ${@base_contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \
+ \
+ ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4", "", d)} \
+ ${@base_contains("DISTRO_FEATURES", "wifi", "iw wpa-supplicant", "", d)} \
+ \
+ tzdata \
+ \
+ cpufrequtils \
+ htop \
+"
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb b/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb
index 1d6ae9eda0..a46f4fac9d 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb
@@ -33,9 +33,9 @@ RDEPENDS_${PN} = "\
netbase \
${@base_contains("MACHINE_FEATURES", "keyboard", "keymaps", "", d)} \
${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
- "
+"
RRECOMMENDS_${PN} = "\
kernel \
${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS} \
- "
+"
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb b/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb
index 88b62b8ad5..fa53a67e78 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-cli-tools.bb
@@ -18,36 +18,36 @@ RCONFLICTS_${PN} += "task-cli-tools"
RCONFLICTS_${PN}-debug += "task-cli-tools-debug"
RDEPENDS_${PN} = "\
- dbus-daemon-proxy \
- dosfstools \
- htop \
- iptables \
- lsof \
- mbuffer \
- mtd-utils \
- nano \
- nfs-utils-client \
- nmon \
- powertop \
- screen \
- socat \
- sysstat \
+ dbus-daemon-proxy \
+ dosfstools \
+ htop \
+ iptables \
+ lsof \
+ mbuffer \
+ mtd-utils \
+ nano \
+ nfs-utils-client \
+ nmon \
+ powertop \
+ screen \
+ socat \
+ sysstat \
"
RDEPENDS_${PN}-debug = "\
- evtest \
- devmem2 \
- i2c-tools \
- gdb \
- procps \
- pxaregs \
- s3c24xx-gpio \
- s3c64xx-gpio \
- serial-forward \
- strace \
- tcpdump \
+ evtest \
+ devmem2 \
+ i2c-tools \
+ gdb \
+ procps \
+ pxaregs \
+ s3c24xx-gpio \
+ s3c64xx-gpio \
+ serial-forward \
+ strace \
+ tcpdump \
"
RRECOMMENDS_${PN}-debug = "\
- ltrace \
+ ltrace \
"