aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd/systemd_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-05-28 09:38:59 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-28 16:42:55 +0200
commitede2ce2942a350394bed0af4a48a2877497b9c22 (patch)
treeb4ccede67ed77197172ccebe600b3b14e19c5965 /meta-oe/recipes-core/systemd/systemd_git.bb
parent7f9dbc16002bacf2ccc040a2de3ddc134e5fbbad (diff)
downloadmeta-openembedded-ede2ce2942a350394bed0af4a48a2877497b9c22.tar.gz
systemd: fix "double getty" problem on serial console with recent kernels
From #systemd: 16:46 < koen> kay: do you know what could have changed in 2.6.39 that system opens a getty on tty0 by itself? 16:48 < kay> nothing in the kernel i could think of 16:48 < koen> I can trigger it just by switching kernels and leaving the rootfs identical 23:53 < mezcalero> koen: btw, it is /lib/systemd/systemd-generators/systemd-getty-generator which spawns gettys 23:53 < mezcalero> on the kernel console automatically 23:53 < mezcalero> it uses /sys/class/tty/console/active for that 23:53 < mezcalero> which eixsts only on recent kernels 00:32 < koen> mezcalero: so what's the best way to avoid double spawning a getty? 00:35 < mezcalero> if if you want a serial getty even if you are not redirecting the console just make sure to use the same service name 00:35 < mezcalero> how exactly are your two getty services called? 00:39 < koen> lrwxrwxrwx 1 root root 41 May 27 22:38 getty@ttyO2.service -> /lib/systemd/system/serial-getty@.service 00:50 < mezcalero> koen: call it serial-getty@ttyO2
Diffstat (limited to 'meta-oe/recipes-core/systemd/systemd_git.bb')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 670a4272e5..6c34f75551 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -18,7 +18,7 @@ PKGV = "v${GITPKGVTAG}"
# Except that PKGV doesn't work in OE-core :(
# PV = "git"
PV = "v28"
-PR = "r0"
+PR = "r1"
inherit autotools vala update-alternatives
@@ -53,7 +53,7 @@ do_install_append() {
sed -i -e s/\@BAUDRATE\@/${@get_baudrate(bb, d)}/g ${WORKDIR}/serial-getty@.service
install ${WORKDIR}/serial-getty@.service ${D}${base_libdir}/systemd/system/
ln -sf ${base_libdir}/systemd/system/serial-getty@.service \
- ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@${@get_console(bb, d)}.service
+ ${D}${sysconfdir}/systemd/system/getty.target.wants/serial-getty@${@get_console(bb, d)}.service
fi
}