aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2011-11-21 09:45:30 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-21 12:08:21 +0100
commit0c1147ad8da559ebc23c54f6c3d39b4c40dbf00a (patch)
tree95c6999ff98d88e6ac70f246cefc6c066c1d1b35 /meta-oe/recipes-core
parentb006355af5ebe0e0465dd8412d918fa042bbda55 (diff)
downloadmeta-openembedded-0c1147ad8da559ebc23c54f6c3d39b4c40dbf00a.tar.gz
systemd: add prerm u-a calls
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 7b0771a00a..228e0e4b3c 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -108,7 +108,6 @@ RRECOMMENDS_${PN} += "kbd kbd-consolefonts \
# TODO:
# u-a for runlevel and telinit
-# u-a prerm
pkg_postinst_systemd () {
update-alternatives --install ${base_sbindir}/init init ${base_bindir}/systemd 300
@@ -117,3 +116,11 @@ update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/syste
update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300
update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300
}
+
+pkg_prerm_systemd () {
+update-alternatives --remove init ${base_bindir}/systemd
+update-alternatives --remove halt ${base_bindir}/systemctl
+update-alternatives --remove reboot ${base_bindir}/systemctl
+update-alternatives --remove shutdown ${base_bindir}/systemctl
+update-alternatives --remove poweroff ${base_bindir}/systemctl
+}