aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-03-06 10:21:15 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-09 07:03:52 +0100
commit112c1f86fc26c960cc2a69266f44e149b60ba307 (patch)
tree138527f34f5413624698199337e824670575e937 /meta-oe/recipes-core
parent81703d249df4d5e03808e9c6b219dd4b227df9c6 (diff)
downloadmeta-openembedded-112c1f86fc26c960cc2a69266f44e149b60ba307.tar.gz
systemd: update to latest git
This is in preparation for the v44 release. * drop 2 patches that aren't needed anymore * fix more endianness problems * fix journal crashes with large files Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/systemd/systemd/0001-docs-fix-build-without-xsltproc.patch41
-rw-r--r--meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch29
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb15
3 files changed, 7 insertions, 78 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd/0001-docs-fix-build-without-xsltproc.patch b/meta-oe/recipes-core/systemd/systemd/0001-docs-fix-build-without-xsltproc.patch
deleted file mode 100644
index 390d65c72a..0000000000
--- a/meta-oe/recipes-core/systemd/systemd/0001-docs-fix-build-without-xsltproc.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 7395173a5af08e9e58aed33e831d0bfc6515891d Mon Sep 17 00:00:00 2001
-From: Koen Kooi <koen@dominion.thruhere.net>
-Date: Sun, 2 Oct 2011 19:54:29 +0200
-Subject: [PATCH 1/2] docs: fix build without xsltproc
-
-Make would choke on missing rules for man/systemd.1
-
-Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-
-Upstream-status: rejected [fix your docbook install]
-
----
- Makefile.am | 5 +++++
- 1 files changed, 5 insertions(+), 0 deletions(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index f1f975f..53f99a1 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -649,6 +649,7 @@ EXTRA_DIST += \
- src/acl-util.h \
- src/logs-show.h
-
-+if HAVE_XSLTPROC
- MANPAGES = \
- man/systemd.1 \
- man/systemctl.1 \
-@@ -721,6 +722,10 @@ EXTRA_DIST += \
- $(XML_IN_FILES) \
- ${nodist_man_MANS:=.in} \
- ${XML_IN_FILES:.xml.in=.html.in}
-+else
-+MANPAGES =
-+MANPAGES_ALIAS =
-+endif
-
- systemd_SOURCES = \
- src/main.c
---
-1.7.2.5
-
diff --git a/meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch b/meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch
deleted file mode 100644
index b41d5ebad9..0000000000
--- a/meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From d228134ff5af3bd0ef1087e9bee66583c1546553 Mon Sep 17 00:00:00 2001
-From: Dirk Eibach <eibach@gdsys.de>
-Date: Wed, 29 Feb 2012 12:45:46 +0100
-Subject: [PATCH] systemd-journald: fix endianess bug
-
-Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
----
-
-Upstream-status: Submitted
-
- src/journal/journal-file.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/src/journal/journal-file.c b/src/journal/journal-file.c
-index 20ca3f6..275caea 100644
---- a/src/journal/journal-file.c
-+++ b/src/journal/journal-file.c
-@@ -238,7 +238,7 @@ static int journal_file_allocate(JournalFile *f, uint64_t offset, uint64_t size)
- if (fstat(f->fd, &f->last_stat) < 0)
- return -errno;
-
-- f->header->arena_size = new_size - htole64(f->header->arena_offset);
-+ f->header->arena_size = htole64(new_size - le64toh(f->header->arena_offset));
-
- return 0;
- }
---
-1.7.7.4
-
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 4a8e9a1996..918b314180 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.freedesktop.org/wiki/Software/systemd"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
-DEPENDS = "xz docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline udev dbus libcap libcgroup tcp-wrappers"
+DEPENDS = "xz kmod docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline udev dbus libcap libcgroup tcp-wrappers"
DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
SERIAL_CONSOLE ?= "115200 /dev/ttyS0"
@@ -14,16 +14,14 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r19"
+PR = "r21"
inherit useradd pkgconfig autotools vala perlnative
-SRCREV = "d26e4270409506cd398875216413b651d6ee7de6"
+SRCREV = "48496df65c3ad1e3ad055d2b4632da7b73211715"
SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
- file://0001-docs-fix-build-without-xsltproc.patch \
file://0002-systemd-logind-don-t-kill-user-processes-on-exit.patch \
- file://0001-systemd-journald-fix-endianess-bug.patch \
${UCLIBCPATCHES} \
"
UCLIBCPATCHES = ""
@@ -45,6 +43,7 @@ EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \
${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \
--disable-gtk \
--enable-xz \
+ --disable-manpages \
"
# There's no docbook-xsl-native, so for the xsltproc check to false
@@ -58,7 +57,7 @@ do_install() {
rm ${D}${base_libdir}/systemd/system/serial-getty* -f
# provide support for initramfs
- ln -s ${base_bindir}/systemd ${D}/init
+ ln -s ${base_libdir}/systemd/systemd ${D}/init
# create dir for journal
install -d ${D}${localstatedir}/log/journal
@@ -134,7 +133,7 @@ RRECOMMENDS_${PN} += "systemd-serialgetty \
# u-a for runlevel and telinit
pkg_postinst_systemd () {
-update-alternatives --install ${base_sbindir}/init init ${base_bindir}/systemd 300
+update-alternatives --install ${base_sbindir}/init init ${base_libdir}/systemd/systemd 300
update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300
update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300
update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300
@@ -142,7 +141,7 @@ update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/s
}
pkg_prerm_systemd () {
-update-alternatives --remove init ${base_bindir}/systemd
+update-alternatives --remove init ${base_libdir}/systemd/systemd
update-alternatives --remove halt ${base_bindir}/systemctl
update-alternatives --remove reboot ${base_bindir}/systemctl
update-alternatives --remove shutdown ${base_bindir}/systemctl