aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-02-29 12:43:04 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-29 14:53:13 +0100
commit3d15d096b6cd691d9b7e7b00c44498b73e9661b5 (patch)
tree517190c436b978b75fbb57bc8cb752c06516dbe0 /meta-oe/recipes-core
parent59de020063c4a5130c4f7e1a997aa32db18575ee (diff)
downloadmeta-openembedded-3d15d096b6cd691d9b7e7b00c44498b73e9661b5.tar.gz
systemd: address logind problem on BE machines
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch29
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch b/meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch
new file mode 100644
index 0000000000..b41d5ebad9
--- /dev/null
+++ b/meta-oe/recipes-core/systemd/systemd/0001-systemd-journald-fix-endianess-bug.patch
@@ -0,0 +1,29 @@
+From d228134ff5af3bd0ef1087e9bee66583c1546553 Mon Sep 17 00:00:00 2001
+From: Dirk Eibach <eibach@gdsys.de>
+Date: Wed, 29 Feb 2012 12:45:46 +0100
+Subject: [PATCH] systemd-journald: fix endianess bug
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+
+Upstream-status: Submitted
+
+ src/journal/journal-file.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/journal/journal-file.c b/src/journal/journal-file.c
+index 20ca3f6..275caea 100644
+--- a/src/journal/journal-file.c
++++ b/src/journal/journal-file.c
+@@ -238,7 +238,7 @@ static int journal_file_allocate(JournalFile *f, uint64_t offset, uint64_t size)
+ if (fstat(f->fd, &f->last_stat) < 0)
+ return -errno;
+
+- f->header->arena_size = new_size - htole64(f->header->arena_offset);
++ f->header->arena_size = htole64(new_size - le64toh(f->header->arena_offset));
+
+ return 0;
+ }
+--
+1.7.7.4
+
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 4c458bd73c..62a326ee08 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,7 +14,7 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r16"
+PR = "r17"
inherit useradd pkgconfig autotools vala perlnative
@@ -23,6 +23,7 @@ SRCREV = "d26e4270409506cd398875216413b651d6ee7de6"
SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
file://0001-docs-fix-build-without-xsltproc.patch \
file://0002-systemd-logind-don-t-kill-user-processes-on-exit.patch \
+ file://0001-systemd-journald-fix-endianess-bug.patch \
${UCLIBCPATCHES} \
"
UCLIBCPATCHES = ""