aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2019-02-22 18:29:48 +0100
committerKhem Raj <raj.khem@gmail.com>2019-02-22 18:14:53 -0800
commit94f89418977020568cc7d1673d2610f7c539ca9e (patch)
treea572de9035952d1716a75db49dde65bcf2def1e4 /meta-oe/recipes-core
parent62a8c64a0254d02363dd9c809f3efb3a047af9a8 (diff)
downloadmeta-openembedded-94f89418977020568cc7d1673d2610f7c539ca9e.tar.gz
meta-openembedded-94f89418977020568cc7d1673d2610f7c539ca9e.tar.bz2
meta-openembedded-94f89418977020568cc7d1673d2610f7c539ca9e.zip
packagegroup-meta-oe: fixup package that now require polkit
After below commits to add polkit as a required distro feature: 97a1a55 polkit: add polkit as a required distro feature c049e02 polkit: inherit distro_features_check We need to propagate that to all recipes that use/need them, such as this packagegroup, otherwise 'world' will fail. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index 96672db9a..5fcf9899b 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -243,7 +243,7 @@ RDEPENDS_packagegroup-meta-oe-support ="\
sjf2410-linux-native satyr sdparm pty-forward-native serial-forward \
sg3-utils sharutils smem spitools srecord ssiapi start-stop-daemon stm32flash \
syslog-ng system-config-keyboard tbb thin-provisioning-tools tokyocabinet \
- tree udisks udisks2 uhubctl unixodbc upower uriparser usb-modeswitch \
+ tree uhubctl unixodbc uriparser usb-modeswitch \
usb-modeswitch-data usbpath uthash utouch-evemu utouch-frame \
vim vim-tiny websocketpp wmiconfig xdelta3 xdg-user-dirs xmlstarlet \
zbar zile \
@@ -251,6 +251,7 @@ RDEPENDS_packagegroup-meta-oe-support ="\
${@bb.utils.contains("DISTRO_FEATURES", "pulseadio bluez4", "libcanberra", "", d)} \
${@bb.utils.contains("DISTRO_FEATURES", "x11 pam", "xorgxrdp xrdp", "", d)} \
${@bb.utils.contains("DISTRO_FEATURES", "bluez4", "procmail", "", d)} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "polkit", "udisks udisks2 upower", "", d)} \
${NE10} \
"