aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-11-25 15:28:52 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-02 09:16:17 +0100
commitefd3696e70a6603f1a45faa4a172433514f0a487 (patch)
treeb72751ba93b050391db05a8e1be7506836b6d515 /meta-oe/recipes-core
parent761639b9d7681c81dd69eaf3a37c32791d6e97fd (diff)
downloadmeta-openembedded-efd3696e70a6603f1a45faa4a172433514f0a487.tar.gz
remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/fakeroot/fakeroot-native_1.18.4.bb2
-rw-r--r--meta-oe/recipes-core/llvm/llvm.inc2
-rw-r--r--meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb2
-rw-r--r--meta-oe/recipes-core/toybox/toybox_0.7.1.bb4
4 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/recipes-core/fakeroot/fakeroot-native_1.18.4.bb b/meta-oe/recipes-core/fakeroot/fakeroot-native_1.18.4.bb
index a27a60b481..9d50ea44a1 100644
--- a/meta-oe/recipes-core/fakeroot/fakeroot-native_1.18.4.bb
+++ b/meta-oe/recipes-core/fakeroot/fakeroot-native_1.18.4.bb
@@ -8,7 +8,7 @@ EXTRA_OECONF = "--program-prefix="
# Compatability for the rare systems not using or having SYSV
python () {
- if d.getVar('HOST_NONSYSV', True) and d.getVar('HOST_NONSYSV', True) != '0':
+ if d.getVar('HOST_NONSYSV') and d.getVar('HOST_NONSYSV') != '0':
d.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ')
}
diff --git a/meta-oe/recipes-core/llvm/llvm.inc b/meta-oe/recipes-core/llvm/llvm.inc
index fa971f38c8..f27261fa93 100644
--- a/meta-oe/recipes-core/llvm/llvm.inc
+++ b/meta-oe/recipes-core/llvm/llvm.inc
@@ -153,7 +153,7 @@ python llvm_populate_packages() {
split_packages = do_split_packages(d, libdir, '^lib(.*)\.so$', 'libllvm${LLVM_RELEASE}-%s', 'Split package for %s', allow_dirs=True, allow_links=True, recursive=True)
split_staticdev_packages = do_split_packages(d, libllvm_libdir, '^lib(.*)\.a$', 'libllvm${LLVM_RELEASE}-%s-staticdev', 'Split staticdev package for %s', allow_dirs=True)
if split_packages:
- pn = d.getVar('PN', True)
+ pn = d.getVar('PN')
d.appendVar('RDEPENDS_' + pn, ' '+' '.join(split_packages))
d.appendVar('RDEPENDS_' + pn + '-dbg', ' '+' '.join(split_dbg_packages))
d.appendVar('RDEPENDS_' + pn + '-staticdev', ' '+' '.join(split_staticdev_packages))
diff --git a/meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb b/meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb
index a46a91c8b9..f11ae7e4d2 100644
--- a/meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb
+++ b/meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb
@@ -18,7 +18,7 @@ PACKAGES = "${PN} ${PN}-dev"
FILES_${PN}-dev = "${includedir}/libintl.h ${libdir}/libintl.a"
INSANE_SKIP_${PN}-dev = "staticdev"
ALLOW_EMPTY_${PN} = "1"
-CFLAGS_append = " -fPIC -Wall -I ../../include ${@['-DSTUB_ONLY', ''][d.getVar('USE_NLS', 1) != 'no']}"
+CFLAGS_append = " -fPIC -Wall -I ../../include ${@['-DSTUB_ONLY', ''][d.getVar('USE_NLS') != 'no']}"
TARGET_CC_ARCH += "${LDFLAGS}"
do_compile() {
diff --git a/meta-oe/recipes-core/toybox/toybox_0.7.1.bb b/meta-oe/recipes-core/toybox/toybox_0.7.1.bb
index defca7016f..032b138552 100644
--- a/meta-oe/recipes-core/toybox/toybox_0.7.1.bb
+++ b/meta-oe/recipes-core/toybox/toybox_0.7.1.bb
@@ -59,8 +59,8 @@ python do_package_prepend () {
# Read links from /etc/toybox.links and create appropriate
# update-alternatives variables
- dvar = d.getVar('D', True)
- pn = d.getVar('PN', True)
+ dvar = d.getVar('D')
+ pn = d.getVar('PN')
target = "/bin/toybox"
f = open('%s/etc/toybox.links' % (dvar), 'r')