aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-27 23:06:28 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-29 02:10:12 -0700
commitceeb9c4cdcc08334e3ad94c4e67f3ab687b5cde2 (patch)
treea432797fdefc0ef491bc0cbe67d2fd414c87fe9a /meta-oe/recipes-dbs
parent5f23d82175a38542b76b5aa2a0d1db680ca68752 (diff)
downloadmeta-openembedded-ceeb9c4cdcc08334e3ad94c4e67f3ab687b5cde2.tar.gz
mongodb: Consolidate COMPATIBLE_HOST
Its only available on fewer arches so express that via COMPATIBLE_HOST wiredtiger is only for 64bit, so add it directly to config args based on bitness Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs')
-rw-r--r--meta-oe/recipes-dbs/mongodb/mongodb_git.bb19
1 files changed, 6 insertions, 13 deletions
diff --git a/meta-oe/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/recipes-dbs/mongodb/mongodb_git.bb
index bcb15e6c5b..d39ab0a314 100644
--- a/meta-oe/recipes-dbs/mongodb/mongodb_git.bb
+++ b/meta-oe/recipes-dbs/mongodb/mongodb_git.bb
@@ -29,26 +29,18 @@ SRC_URI_append_libc-musl ="\
"
S = "${WORKDIR}/git"
-# Wiredtiger supports only 64-bit platforms
-PACKAGECONFIG_x86-64 ??= "tcmalloc wiredtiger"
-PACKAGECONFIG_aarch64 ??= "tcmalloc wiredtiger"
+COMPATIBLE_HOST ?= '(x86_64|i.86|powerpc64|arm|aarch64).*-linux'
+
+COMPATIBLE_HOST_arm = "null"
+COMPATIBLE_HOST_libc-musl_x86 = "null"
+
PACKAGECONFIG ??= "tcmalloc"
# gperftools compilation fails for arm below v7 because of missing support of
# dmb operation. So we use system-allocator instead of tcmalloc
PACKAGECONFIG_remove_armv6 = "tcmalloc"
PACKAGECONFIG_remove_libc-musl = "tcmalloc"
-#std::current_exception is undefined for arm < v6
-COMPATIBLE_MACHINE_armv4 = "(!.*armv4).*"
-COMPATIBLE_MACHINE_armv5 = "(!.*armv5).*"
-COMPATIBLE_MACHINE_armv7a = "(!.*armv7a).*"
-COMPATIBLE_MACHINE_armv7ve = "(!.*armv7ve).*"
-COMPATIBLE_MACHINE_powerpc = "(!.*ppc).*"
-# https://jira.mongodb.org/browse/SERVER-16898
-COMPATIBLE_HOST_mipsarch = "null"
-
PACKAGECONFIG[tcmalloc] = "--use-system-tcmalloc,--allocator=system,gperftools,"
-PACKAGECONFIG[wiredtiger] = "--wiredtiger=on,--wiredtiger=off,,"
EXTRA_OESCONS = "--prefix=${D}${prefix} \
LIBPATH=${STAGING_LIBDIR} \
@@ -62,6 +54,7 @@ EXTRA_OESCONS = "--prefix=${D}${prefix} \
--js-engine=none \
--nostrip \
--endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \
+ --wiredtiger=${@['off','on'][d.getVar('SITEINFO_BITS') != '32']} \
${PACKAGECONFIG_CONFARGS} \
mongod mongos"