aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorFrederic PAUT <frederic.paut@linux.intel.com>2013-10-03 13:32:55 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-05 12:40:35 +0200
commit9142d13a68045e3f483a4651b570f607c3d2de20 (patch)
tree2e950db8dacb6d0891521b4567e01a3b4607f6f7 /meta-oe/recipes-devtools
parent7a541bd4baab7e6f23f998fcf6509ee2817b018b (diff)
downloadmeta-openembedded-9142d13a68045e3f483a4651b570f607c3d2de20.tar.gz
python-cloudeebus: Add recipe vor 0.6.0
Cloudeebus, D-Bus for the cloud, is a component that provides D-Bus proxies for JavaScript. Unlike a web runtime, it doesn't rely on any custom web browser API, but on HTML5 WebSockets and python D-Bus bindings. Cloudeebus can be used as a web API fast prototyping tool. Signed-off-by: Frederic PAUT <frederic.paut@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/python/python-cloudeebus_0.6.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-cloudeebus_0.6.0.bb b/meta-oe/recipes-devtools/python/python-cloudeebus_0.6.0.bb
new file mode 100644
index 0000000000..5c1fa9cdf8
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-cloudeebus_0.6.0.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "A component which enables calling DBus methods and registering on DBus signals from Javascript"
+HOMEPAGE = "https://github.com/01org/cloudeebus"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI = "git://github.com/01org/cloudeebus.git;protocol=http;branch=master "
+SRCREV = "b5cc957eeabfe98cb996baf8e5a0ac848993c3d4"
+
+S = "${WORKDIR}/git"
+
+inherit distutils
+
+DEPENDS_${PN} = "python python-setuptools"
+RDEPENDS_${PN} = "python python-dbus python-json python-argparse python-pygobject python-autobahn python-twisted python-subprocess"
+
+do_install_prepend() {
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}/${PN}
+}
+
+DISTUTILS_INSTALL_ARGS = "--root=${D} \
+ --single-version-externally-managed \
+ --prefix=${prefix} \
+ --install-lib=${PYTHON_SITEPACKAGES_DIR} \
+ --install-data=${datadir}"
+
+do_install_append() {
+ distutils_do_install
+ install -d ${D}${datadir}/doc/${BPN}/
+ install -m 0644 ${S}/README.md ${D}${datadir}/doc/${BPN}/
+}
+
+FILES_${PN} += "${datadir}/cloudeebus"
+FILES_${PN} += "${sysconfdir}/dbus-1/system.d/org.cloudeebus.conf"
+