aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-02 11:32:35 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-02 13:00:02 +0100
commit02147ad225cced787bf3b1ab607fd38f8e132b47 (patch)
tree8a00d5dbd553f77f7bd04dd0884c658b757b3287 /meta-oe/recipes-devtools
parente2b5b7e2464c4ffe4b3c11a222d0760baad809dd (diff)
downloadmeta-openembedded-02147ad225cced787bf3b1ab607fd38f8e132b47.tar.gz
python-tornado: add patch to fix crasher
socket.gaierror: [Errno 3] invalid value for ai_flags. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch32
-rw-r--r--meta-oe/recipes-devtools/python/python-tornado_git.bb6
2 files changed, 36 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch b/meta-oe/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch
new file mode 100644
index 0000000000..a3efbcaac8
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch
@@ -0,0 +1,32 @@
+From d7fb0a6ef3f3cbdfc1f21f5a67d54fa9d2c1e183 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Wed, 2 Nov 2011 11:07:24 +0100
+Subject: [PATCH] disable AI_ADDRCONFIG flag
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+
+Upstream-status: unknown
+---
+ tornado/netutil.py | 6 ------
+ 1 files changed, 0 insertions(+), 6 deletions(-)
+
+diff --git a/tornado/netutil.py b/tornado/netutil.py
+index cfff0ba..c181f24 100644
+--- a/tornado/netutil.py
++++ b/tornado/netutil.py
+@@ -238,12 +238,6 @@ def bind_sockets(port, address=None, family=socket.AF_UNSPEC, backlog=128):
+ if address == "":
+ address = None
+ flags = socket.AI_PASSIVE
+- if hasattr(socket, "AI_ADDRCONFIG"):
+- # AI_ADDRCONFIG ensures that we only try to bind on ipv6
+- # if the system is configured for it, but the flag doesn't
+- # exist on some platforms (specifically WinXP, although
+- # newer versions of windows have it)
+- flags |= socket.AI_ADDRCONFIG
+ for res in socket.getaddrinfo(address, port, family, socket.SOCK_STREAM,
+ 0, flags):
+ af, socktype, proto, canonname, sockaddr = res
+--
+1.7.2.5
+
diff --git a/meta-oe/recipes-devtools/python/python-tornado_git.bb b/meta-oe/recipes-devtools/python/python-tornado_git.bb
index b630785c57..11cad0ce1d 100644
--- a/meta-oe/recipes-devtools/python/python-tornado_git.bb
+++ b/meta-oe/recipes-devtools/python/python-tornado_git.bb
@@ -3,9 +3,11 @@ LICENSE = "Apache"
LIC_FILES_CHKSUM = "file://README;md5=e7fb9954003d7cd93322ccf282210d1c"
PV = "2.1.1"
-PR = "r2"
+PR = "r3"
SRCREV = "066a0c38fb819419b8422980b61a0fd2f6ee4739"
-SRC_URI = "git://github.com/facebook/tornado.git"
+SRC_URI = "git://github.com/facebook/tornado.git \
+ file://0001-disable-AI_ADDRCONFIG-flag.patch \
+ "
S = "${WORKDIR}/git"