aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/redis/redis
diff options
context:
space:
mode:
authorStephen Arnold <sarnold@vctlabs.com>2016-06-07 17:14:58 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-15 12:13:14 +0200
commitaf6af8621ed8b93605a5db98d1ff8006f2ef1dff (patch)
treec5ebd4677d3d5755244a3ef0553e9439a4ce950e /meta-oe/recipes-extended/redis/redis
parent548effebf1dc1e80c7898b92ca29b750daf403d5 (diff)
downloadmeta-openembedded-af6af8621ed8b93605a5db98d1ff8006f2ef1dff.tar.gz
redis: fix hiredis build so it's less failure-prone and links properly
This patch resets the default OPT flags to -O2 and adds the missing ranlib command to index the static library. Signed-off-by: Stephen Arnold <sarnold@vctlabs.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/redis/redis')
-rw-r--r--meta-oe/recipes-extended/redis/redis/hiredis-update-Makefile-to-add-symbols-to-staticlib.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/redis/redis/hiredis-update-Makefile-to-add-symbols-to-staticlib.patch b/meta-oe/recipes-extended/redis/redis/hiredis-update-Makefile-to-add-symbols-to-staticlib.patch
new file mode 100644
index 0000000000..2b3b587936
--- /dev/null
+++ b/meta-oe/recipes-extended/redis/redis/hiredis-update-Makefile-to-add-symbols-to-staticlib.patch
@@ -0,0 +1,19 @@
+--- redis-3.0.2/deps/hiredis/Makefile.orig 2016-05-06 19:36:26.179003036 -0700
++++ redis-3.0.2/deps/hiredis/Makefile 2016-05-06 19:40:15.341340736 -0700
+@@ -25,7 +25,7 @@
+
+ # Fallback to gcc when $CC is not in $PATH.
+ CC?=$(shell sh -c 'type $(CC) >/dev/null 2>/dev/null && echo $(CC) || echo gcc')
+-OPTIMIZATION?=-O3
++OPTIMIZATION?=-O2
+ WARNINGS=-Wall -W -Wstrict-prototypes -Wwrite-strings
+ DEBUG?= -g -ggdb
+ REAL_CFLAGS=$(OPTIMIZATION) -fPIC $(CFLAGS) $(WARNINGS) $(DEBUG) $(ARCH)
+@@ -68,6 +68,7 @@
+
+ $(STLIBNAME): $(OBJ)
+ $(STLIB_MAKE_CMD) $(OBJ)
++ $(RANLIB) $@
+
+ dynamic: $(DYLIBNAME)
+ static: $(STLIBNAME)