aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-04-11 15:37:57 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-20 11:19:09 +0200
commitb0a2b9011ba72eec5897841b94d68ba93cd15450 (patch)
treee2de2445af21e4430077c708d703455fee4bbf19 /meta-oe/recipes-extended
parent42caea1d67c320c3e2b6622fe3b4de49763095e6 (diff)
downloadmeta-openembedded-b0a2b9011ba72eec5897841b94d68ba93cd15450.tar.gz
liblockfile: set default mailgroup and install libnfslock
* Set the default mailgroup to 'mail' or it will use 'root'. * Set --with-libnfslock so it builds and install libnfslock. * The patch is to fix nfslib build failure and add missing soname lib. * No need to override the do_install, set EXTRA_OEMAKE instead. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/liblockfile/liblockfile-1.09/liblockfile-fix-nfslib-and-soname.patch54
-rw-r--r--meta-oe/recipes-extended/liblockfile/liblockfile_1.09.bb15
2 files changed, 65 insertions, 4 deletions
diff --git a/meta-oe/recipes-extended/liblockfile/liblockfile-1.09/liblockfile-fix-nfslib-and-soname.patch b/meta-oe/recipes-extended/liblockfile/liblockfile-1.09/liblockfile-fix-nfslib-and-soname.patch
new file mode 100644
index 0000000000..ffd7a40fab
--- /dev/null
+++ b/meta-oe/recipes-extended/liblockfile/liblockfile-1.09/liblockfile-fix-nfslib-and-soname.patch
@@ -0,0 +1,54 @@
+Upstream-Status: Inappropriate [no upstream]
+
+* nfslib should use NVER instead of VER
+* install the missing soname library
+
+Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+---
+ Makefile.in | 9 ++++++---
+ 1 files changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 836ca9b..a589fb8 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -27,7 +27,7 @@ install: @INSTALL_TARGETS@
+
+ static: liblockfile.a dotlockfile
+ shared: liblockfile.so dotlockfile
+-nfslib: nfslock.so.$(VER)
++nfslib: nfslock.so.$(NVER)
+
+ liblockfile.a: lockfile.o
+ $(AR) rv liblockfile.a lockfile.o
+@@ -36,7 +36,7 @@ liblockfile.so: liblockfile.a
+ $(CC) -fPIC -shared -Wl,-soname,liblockfile.so.1 \
+ -o liblockfile.so lockfile.o $(LDFLAGS) -lc
+
+-nfslock.so.$(VER): nfslock.o
++nfslock.so.$(NVER): nfslock.o
+ $(CC) -fPIC -shared -Wl,-soname,nfslock.so.0 \
+ -o nfslock.so.$(NVER) nfslock.o $(LDFLAGS)
+
+@@ -59,6 +59,7 @@ install_shared: shared install_common
+ install -m 755 liblockfile.so \
+ $(ROOT)$(libdir)/liblockfile.so.$(VER)
+ ln -s liblockfile.so.$(VER) $(ROOT)$(libdir)/liblockfile.so
++ ln -s liblockfile.so.$(VER) $(ROOT)$(libdir)/liblockfile.so.1
+ if test "$(ROOT)" = ""; then @LDCONFIG@; fi
+
+ install_common:
+@@ -72,7 +73,9 @@ install_common:
+
+ install_nfslib: nfslib
+ install -d $(ROOT)$(nfslockdir)
+- install -m 755 nfslock.so.$(VER) $(ROOT)$(nfslockdir)
++ install -m 755 nfslock.so.$(NVER) $(ROOT)$(nfslockdir)
++ ln -sf nfslock.so.$(NVER) $(ROOT)$(libdir)/nfslock.so
++ ln -sf nfslock.so.$(NVER) $(ROOT)$(libdir)/nfslock.so.0
+ if test "$(ROOT)" = ""; then @LDCONFIG@; fi
+
+ clean:
+--
+1.7.9.5
+
diff --git a/meta-oe/recipes-extended/liblockfile/liblockfile_1.09.bb b/meta-oe/recipes-extended/liblockfile/liblockfile_1.09.bb
index 3ef52cf671..fa68fd0612 100644
--- a/meta-oe/recipes-extended/liblockfile/liblockfile_1.09.bb
+++ b/meta-oe/recipes-extended/liblockfile/liblockfile_1.09.bb
@@ -7,6 +7,7 @@ SRC_URI = "${DEBIAN_MIRROR}/main/libl/liblockfile/liblockfile_1.09.orig.tar.gz \
file://install.patch \
file://configure.patch \
file://ldflags.patch \
+ file://liblockfile-fix-nfslib-and-soname.patch \
"
SRC_URI[md5sum] = "2aa269e4405ee8235ff17d1b357c6ae8"
@@ -14,9 +15,15 @@ SRC_URI[sha256sum] = "16979eba05396365e1d6af7100431ae9d32f9bc063930d1de66298a069
inherit autotools
-EXTRA_OECONF = "--enable-shared --enable-static"
+# set default mailgroup to mail
+# --with-libnfslock specify where to install nfslock.so.NVER
+EXTRA_OECONF = "--enable-shared --enable-static \
+ --with-mailgroup=mail \
+ --with-libnfslock=${libdir} \
+"
-do_install () {
- oe_runmake 'ROOT=${D}' INSTGRP='' install
-}
+# Makefile using ROOT not DESTDIR
+EXTRA_OEMAKE += "ROOT=${D}"
+FILES_${PN} += "${libdir}/nfslock.so.*"
+FILES_${PN}-dev += "${libdir}/nfslock.so"