aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-04-30 11:54:33 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-05-04 10:05:32 +0200
commit0c78b561ef136078b1090c9d2f38f033b90ad8b4 (patch)
tree852014043d5af87a701d70796c9523a4821ac02a /meta-oe/recipes-extended
parent328cc40a12cc2e2d70fbfd5c37b6dbf914358bee (diff)
downloadmeta-openembedded-0c78b561ef136078b1090c9d2f38f033b90ad8b4.tar.gz
gtkmathview: fix build with gcc-4.7
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/mml-widget/gtkmathview/mathview-gcc47x.diff48
-rw-r--r--meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb3
2 files changed, 50 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/mml-widget/gtkmathview/mathview-gcc47x.diff b/meta-oe/recipes-extended/mml-widget/gtkmathview/mathview-gcc47x.diff
new file mode 100644
index 0000000000..11b7260045
--- /dev/null
+++ b/meta-oe/recipes-extended/mml-widget/gtkmathview/mathview-gcc47x.diff
@@ -0,0 +1,48 @@
+../../../src/frontend/common/TemplateBuilder.hh:50:113: warning: 'linkerAssoc' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
+../../../src/frontend/common/TemplateBuilder.hh:50:113: note: declarations in dependent base 'custom_reader_Builder' are not found by unqualified lookup
+../../../src/frontend/common/TemplateBuilder.hh:50:113: note: use 'this->linkerAssoc' instead
+../../../src/frontend/common/TemplateBuilder.hh:54:111: error: redeclaration of 'SmartPtr<BoxMLDecorElement> elem'
+../../../src/frontend/common/TemplateBuilder.hh:50:49: error: 'SmartPtr<BoxMLDecorElement> elem' previously declared here
+../../../src/frontend/common/TemplateBuilder.hh:55:2: warning: 'linkerAdd' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
+../../../src/frontend/common/TemplateBuilder.hh:55:2: note: declarations in dependent base 'custom_reader_Builder' are not found by unqualified lookup
+../../../src/frontend/common/TemplateBuilder.hh:55:2: note: use 'this->linkerAdd' instead
+
+--- gtkmathview-0.8.0.orig/src/frontend/common/TemplateBuilder.hh 2007-08-17 12:02:34.000000000 +0200
++++ gtkmathview-0.8.0/src/frontend/common/TemplateBuilder.hh 2012-04-30 11:45:07.000000000 +0200
+@@ -47,12 +47,13 @@
+ SmartPtr<typename ElementBuilder::type>
+ getElement(const typename Model::Element& el) const
+ {
+- if (SmartPtr<typename ElementBuilder::type> elem = smart_cast<typename ElementBuilder::type>(linkerAssoc(el)))
++ SmartPtr<typename ElementBuilder::type> elem = NULL;
++ if (elem = smart_cast<typename ElementBuilder::type>(this->linkerAssoc(el)))
+ return elem;
+ else
+ {
+- SmartPtr<typename ElementBuilder::type> elem = ElementBuilder::type::create(ElementBuilder::getContext(*this));
+- linkerAdd(el, elem);
++ elem = ElementBuilder::type::create(ElementBuilder::getContext(*this));
++ this->linkerAdd(el, elem);
+ return elem;
+ }
+ }
+--- gtkmathview-0.8.0.orig/mathmlsvg/main.cc 2012-04-30 11:35:19.000000000 +0200
++++ gtkmathview-0.8.0/mathmlsvg/main.cc 2012-04-30 11:51:19.000000000 +0200
+@@ -20,6 +20,7 @@
+
+ #include <cassert>
+ #include <fstream>
++#include <unistd.h>
+ #include <string.h>
+ #include <popt.h>
+
+--- gtkmathview-0.8.0.orig/mathmlps/main.cc 2012-04-30 11:35:19.000000000 +0200
++++ gtkmathview-0.8.0/mathmlps/main.cc 2012-04-30 11:50:57.000000000 +0200
+@@ -20,6 +20,7 @@
+
+ #include <cassert>
+ #include <fstream>
++#include <unistd.h>
+ #include <string.h>
+ #include <popt.h>
+
diff --git a/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb b/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb
index c8e611a483..67cb32584d 100644
--- a/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb
+++ b/meta-oe/recipes-extended/mml-widget/gtkmathview_0.8.0.bb
@@ -4,10 +4,11 @@ DEPENDS = "t1lib gtk+ popt libxslt libxml2"
LICENSE = "LGPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz \
file://mathview-gcc43x.diff \
+ file://mathview-gcc47x.diff \
"
SRC_URI[md5sum] = "b53564e553728d4b69f7d366dfeb5299"
SRC_URI[sha256sum] = "1dc30175da6a3c560a7d62d1abe1c2f9829d988e6f1a7c5e766544575c558c43"