aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorYann Dirson <yann@blade-group.com>2020-09-09 10:45:38 +0200
committerKhem Raj <raj.khem@gmail.com>2020-09-10 01:24:33 -0700
commit52fbd36e62e8237e0df13c3ed9ac997c5f96e82b (patch)
tree8ba7a7e3fefda72ff83e21564bab3dde6dcabd8b /meta-oe/recipes-extended
parent5d28b4ec75fc5836c8d7acefd5fbeb2d70367e33 (diff)
downloadmeta-openembedded-52fbd36e62e8237e0df13c3ed9ac997c5f96e82b.tar.gz
libcec: build with Linux CEC API
The Linux CEC API is available in linux-kernel-headers 4.10 and newer, and supported since libcec 5.0.0, though they still default to the legacy Raspberry Pi API. Signed-off-by: Yann Dirson <yann@blade-group.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/libcec/libcec_6.0.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb b/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
index c4aeb8c555..94d967f4c8 100644
--- a/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
+++ b/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
@@ -20,6 +20,10 @@ S = "${WORKDIR}/git"
inherit cmake pkgconfig
+# default config is for RaspberryPi API, use the Linux 4.10+ API by default
+PLATFORM_CMAKE_FLAGS ?= "-DHAVE_LINUX_API=1 -DHAVE_RPI_API=0"
+EXTRA_OECMAKE += "${PLATFORM_CMAKE_FLAGS}"
+
# Put client tools into a separate package
PACKAGE_BEFORE_PN += "${PN}-tools"
FILES_${PN}-tools = "${bindir}"