aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorHaiqing Bai <Haiqing.Bai@windriver.com>2020-09-15 17:18:49 +0800
committerKhem Raj <raj.khem@gmail.com>2020-09-15 20:51:09 -0700
commit7a0edf425e4b930dd8e246269d1fbfefc300d907 (patch)
tree4a95573d5613853c062e92caa7797b13a2424806 /meta-oe/recipes-extended
parentd916d5970376e1b6ea20ad3b9161833af8d3268d (diff)
downloadmeta-openembedded-7a0edf425e4b930dd8e246269d1fbfefc300d907.tar.gz
rsyslog: fix wrong option of PACKAGECONFIG[valgrind]
The source configure.ac shows: --enable-valgrind: Enable somes special code that rsyslog core developers consider useful for testing.Do NOT use if you don't exactly know what you are doing, except if told so by rsyslog developers. NOT to be used by distro maintainers for building regular packages. --without-valgrind-testbench: Don't use valgrind in testbench PACKAGECONFIG[valgrind] should use '--without-valgrind-testbench' And after this fix, the code which removes the valgrind depended ptest cases for arm,mips is no longer needed. Signed-off-by: Haiqing Bai <Haiqing.Bai@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog_8.2006.0.bb8
1 files changed, 1 insertions, 7 deletions
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog_8.2006.0.bb b/meta-oe/recipes-extended/rsyslog/rsyslog_8.2006.0.bb
index 524cd9ead1..b6c2a991fc 100644
--- a/meta-oe/recipes-extended/rsyslog/rsyslog_8.2006.0.bb
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog_8.2006.0.bb
@@ -76,7 +76,7 @@ PACKAGECONFIG[mysql] = "--enable-mysql,--disable-mysql,mysql5,"
PACKAGECONFIG[postgresql] = "--enable-pgsql,--disable-pgsql,postgresql,"
PACKAGECONFIG[libdbi] = "--enable-libdbi,--disable-libdbi,libdbi,"
PACKAGECONFIG[mail] = "--enable-mail,--disable-mail,,"
-PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
+PACKAGECONFIG[valgrind] = ",--without-valgrind-testbench,valgrind,"
do_configure_prepend() {
sed -i -e 's|python |python3 |g' ${S}/tests/*.sh
@@ -106,12 +106,6 @@ do_install_ptest() {
# fix the abs_top_builddir
sed -i 's,^\(abs_top_builddir = \).*,\1${PTEST_PATH}/,' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
- # valgrind is not compatible with arm and mips,
- # so remove related test cases if there is no valgrind.
- if [ x${VALGRIND} = x ]; then
- sed -i '/udp-msgreduc-/d' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
- fi
-
# install test-driver
install -m 644 ${S}/test-driver ${D}${PTEST_PATH}