aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-11-01 11:18:57 -0800
committerKhem Raj <raj.khem@gmail.com>2020-11-02 09:00:52 -0800
commitac4ccd2fbbb599d75ca4051911fcbaca39dbe6d7 (patch)
treebcedecb9cf209d1ad85eca628fbcaa4dce7bca57 /meta-oe/recipes-extended
parent5380eb42d6453e6a7ed83b408a1c73350e3e03e3 (diff)
downloadmeta-openembedded-ac4ccd2fbbb599d75ca4051911fcbaca39dbe6d7.tar.gz
minifi-cpp: Fix build with riscv64/clang
Do not use lld linker on risc64, since it errors out riscv64-yoe-linux-ld.lld: error: init.c:(.text+0x0): relocation R_RISCV_ALIGN requires unimplemented linker relaxation; recompile with -mno-relax Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb b/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
index 9b66c48e37..3815220cb3 100644
--- a/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
+++ b/meta-oe/recipes-extended/minifi-cpp/minifi-cpp_0.7.0.bb
@@ -58,7 +58,11 @@ EXTRA_OECMAKE += " \
"
EXTRA_OECMAKE_append_toolchain-clang = " -DCMAKE_RANLIB=${STAGING_BINDIR_TOOLCHAIN}/${TARGET_PREFIX}llvm-ranlib"
LDFLAGS_append_toolchain-clang = " -fuse-ld=lld"
+
+# RV lld errors out:
+# riscv64-yoe-linux-ld.lld: error: init.c:(.text+0x0): relocation R_RISCV_ALIGN requires unimplemented linker relaxation; recompile with -mno-relax
LDFLAGS_remove_riscv32 = "-fuse-ld=lld"
+LDFLAGS_remove_riscv64 = "-fuse-ld=lld"
# There are endian issues when communicating with the x86 nifi on the the mips and the ppc machines.
COMPATIBLE_MACHINE_mips = "(!.*mips).*"